summaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-04-21 17:40:55 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-04-21 17:40:55 +0100
commit5df6deaa32e4f6d0a8985403970a137270491991 (patch)
treebfc61fc292038a9cf5c35e0dccc8d7c101e96085 /meta-openmoko
parent12856d95a7e729914f8d0dbe55d9c28df65bc718 (diff)
downloadopenembedded-core-5df6deaa32e4f6d0a8985403970a137270491991.tar.gz
openembedded-core-5df6deaa32e4f6d0a8985403970a137270491991.tar.bz2
openembedded-core-5df6deaa32e4f6d0a8985403970a137270491991.zip
puslseaudio: Upgrade to 0.9.10
Upgrade to 0.9.10, moving pulseaudio to meta-moblin cleaning up and merging in some changes from OE.dev. Also add libcanberra 0.10. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch25
-rw-r--r--meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch15
-rw-r--r--meta-openmoko/packages/pulseaudio/files/fix-shm.patch20
-rw-r--r--meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch18
-rw-r--r--meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse2
-rw-r--r--meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch15
-rw-r--r--meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb15
-rw-r--r--meta-openmoko/packages/pulseaudio/pulse.inc101
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff19
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff15
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch24
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch48
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch17
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb21
14 files changed, 0 insertions, 355 deletions
diff --git a/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch b/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch
deleted file mode 100644
index 31d147be7d..0000000000
--- a/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: pulseaudio-0.9.9/configure.ac
-===================================================================
---- pulseaudio-0.9.9.orig/configure.ac 2008-01-24 01:06:06.000000000 +0000
-+++ pulseaudio-0.9.9/configure.ac 2008-02-05 17:45:59.000000000 +0000
-@@ -139,8 +139,8 @@
- ret=$?
- rm -f conftest.o conftest
- if test $ret -eq 0 ; then
-- AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().])
-- AC_MSG_RESULT([yes])
-+dnl AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().])
-+ AC_MSG_RESULT([no])
- else
- AC_MSG_RESULT([no])
- fi
-@@ -325,8 +325,7 @@
- rm -f conftest.o conftest
-
- if test $ret -eq 0 ; then
-- AC_DEFINE([HAVE_PTHREAD_PRIO_INHERIT], 1, [Have PTHREAD_PRIO_INHERIT.])
-- AC_MSG_RESULT([yes])
-+ AC_MSG_RESULT([no])
- else
- AC_MSG_RESULT([no])
- fi
diff --git a/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch b/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch
deleted file mode 100644
index f8ac5674a6..0000000000
--- a/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: pulseaudio-0.9.8/src/Makefile.am
-===================================================================
---- pulseaudio-0.9.8.orig/src/Makefile.am
-+++ pulseaudio-0.9.8/src/Makefile.am
-@@ -1424,8 +1424,8 @@
- # HAL
- libdbus_util_la_SOURCES = modules/dbus-util.c modules/dbus-util.h
- libdbus_util_la_LDFLAGS = -avoid-version
--libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) libpulsecore.la
--libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS)
-+libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) $(DBUS_LIBS) libpulsecore.la
-+libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS) $(DBUS_CFLAGS)
-
- module_hal_detect_la_SOURCES = modules/module-hal-detect.c
- module_hal_detect_la_LDFLAGS = -module -avoid-version
diff --git a/meta-openmoko/packages/pulseaudio/files/fix-shm.patch b/meta-openmoko/packages/pulseaudio/files/fix-shm.patch
deleted file mode 100644
index 3bf61d0d34..0000000000
--- a/meta-openmoko/packages/pulseaudio/files/fix-shm.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-# fixes building against uclibc
-# fixed upstream, see http://www.pulseaudio.org/ticket/200
-Index: pulseaudio-0.9.9/src/pulsecore/shm.c
-===================================================================
---- pulseaudio-0.9.9/src/pulsecore/shm.c (revision 1971)
-+++ pulseaudio-0.9.9/src/pulsecore/shm.c (revision 2110)
-@@ -319,4 +319,5 @@
- int pa_shm_cleanup(void) {
-
-+#ifdef HAVE_SHM_OPEN
- #ifdef SHM_PATH
- DIR *d;
-@@ -376,5 +377,6 @@
-
- closedir(d);
--#endif
-+#endif /* SHM_PATH */
-+#endif /* HAVE_SHM_OPEN */
-
- return 0;
diff --git a/meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch b/meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch
deleted file mode 100644
index 34ad026e4d..0000000000
--- a/meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-| fix for more strict syntax compliance in gcc4.x
-| pulsecore/core-util.c: In function 'pa_raise_priority':
-| pulsecore/core-util.c:547: error: label at end of compound statement
-| Signed off: mickey@openmoko.org
-|
-Index: pulseaudio-0.9.6/src/pulsecore/core-util.c
-===================================================================
---- pulseaudio-0.9.6.orig/src/pulsecore/core-util.c
-+++ pulseaudio-0.9.6/src/pulsecore/core-util.c
-@@ -535,7 +535,7 @@ void pa_raise_priority(void) {
- pa_log_info("Successfully gained high priority class.");
- #endif
-
--fail:
-+fail:;
-
- #if defined(HAVE_SYS_CAPABILITY_H)
- if (caps) {
diff --git a/meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse b/meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse
deleted file mode 100644
index 5b1998032b..0000000000
--- a/meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse
+++ /dev/null
@@ -1,2 +0,0 @@
-# <type> <owner> <group> <mode> <path> <linksource>
-d pulse pulse 0755 /var/run/pulse none
diff --git a/meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch b/meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch
deleted file mode 100644
index 51161dbe0f..0000000000
--- a/meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-http://cvs.fedoraproject.org/viewcvs/devel/libatomic_ops/libatomic_ops-1.2-ppclwzfix.patch
-
-* add fix for bad variable handling on PPC
-
---- libatomic_ops-1.2.orig/src/atomic_ops/sysdeps/gcc/powerpc.h 2007-05-29 19:29:52.000000000 +0200
-+++ libatomic_ops-1.2/src/atomic_ops/sysdeps/gcc/powerpc.h 2007-05-29 19:30:48.000000000 +0200
-@@ -72,7 +72,7 @@
- /* registers. I always got "impossible constraint" when I */
- /* tried the "y" constraint. */
- __asm__ __volatile__ (
-- "lwz %0,%1\n"
-+ "lwz%U1%X1 %0,%1\n"
- "cmpw cr7,%0,%0\n"
- "bne- cr7,1f\n"
- "1: isync\n"
diff --git a/meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb b/meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb
deleted file mode 100644
index 0563eb6382..0000000000
--- a/meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "A library for atomic integer operations"
-LICENSE = "MIT"
-
-PR = "r1"
-
-SRC_URI = "http://www.hpl.hp.com/research/linux/atomic_ops/download/libatomic_ops-1.2.tar.gz \
- file://fedora/libatomic_ops-1.2-ppclwzfix.patch;patch=1"
-
-S = "${WORKDIR}/libatomic_ops-${PV}"
-
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/meta-openmoko/packages/pulseaudio/pulse.inc b/meta-openmoko/packages/pulseaudio/pulse.inc
deleted file mode 100644
index 4b13980cc4..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulse.inc
+++ /dev/null
@@ -1,101 +0,0 @@
-DESCRIPTION = "Pulseaudio is a sound server for Linux and Unix-like operating systems."
-HOMEPAGE = "http://www.pulseaudio.org"
-AUTHOR = "Lennart Poettering"
-SECTION = "libs/multimedia"
-LICENSE = "LGPL"
-DEPENDS = "libatomics-ops liboil avahi libsamplerate0 libsndfile1 libtool hal"
-# optional
-DEPENDS += "alsa-lib glib-2.0"
-
-SRC_URI = "http://0pointer.de/lennart/projects/pulseaudio/pulseaudio-${PV}.tar.gz \
- file://gcc4-compile-fix.patch;patch=1 \
- file://volatiles.04_pulse"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "\
- --disable-lynx \
- --without-x \
- --without-jack \
- --with-glib \
- --with-alsa \
- --with-oss \
- --with-hal \
-"
-
-PARALLEL_MAKE = ""
-
-export TARGET_PFPU = "${TARGET_FPU}"
-
-# TODO: Use more fine granular version
-#OE_LT_RPATH_ALLOW=":${libdir}/pulse-0.9:"
-OE_LT_RPATH_ALLOW = "any"
-OE_LT_RPATH_ALLOW[export]="1"
-
-do_stage() {
- autotools_stage_all
-}
-
-do_install_append() {
- install -d ${D}${sysconfdir}/default/volatiles
- install -m 0644 ${WORKDIR}/volatiles.04_pulse ${D}${sysconfdir}/default/volatiles/volatiles.04_pulse
-
- if [ "x${TARGET_PFPU}" == "xsoft" ] ; then
- sed -i -e s:\;\ resample-method\ =\ sinc-fastest:resample-method\ =\ trivial: ${D}${sysconfdir}/pulse/daemon.conf
- fi
-}
-
-PACKAGES =+ "libpulsecore libpulse libpulse-simple libpulse-browse libpulse-mainloop-glib \
- pulseaudio-server pulseaudio-misc pulseaudio-gconf-helper"
-
-#upgrade path:
-RREPLACES_pulseaudio-server = "libpulse-bin libpulse-conf"
-
-PACKAGES_DYNAMIC = "pulseaudio-lib* pulseaudio-module* libpulse-lib* libpulse-module* "
-
-FILES_libpulsecore = "${libdir}/libpulsecore.so.*"
-FILES_libpulse = "${libdir}/libpulse.so.*"
-FILES_libpulse-simple = "${libdir}/libpulse-simple.so.*"
-FILES_libpulse-browse = "${libdir}/libpulse-browse.so.*"
-FILES_libpulse-mainloop-glib = "${libdir}/libpulse-mainloop-glib.so.*"
-
-FILES_${PN}-dbg += "${libexecdir}/pulse/.debug \
- ${libdir}/pulse-0.9/modules/.debug"
-FILES_${PN}-dev += "${libdir}/pulse-0.9/modules/*.la"
-FILES_${PN}-conf = "${sysconfdir}"
-FILES_${PN}-bin = "${bindir}/* \
- ${sysconfdir}/default/volatiles/volatiles.04_pulse"
-FILES_${PN}-server = "${bindir}/pulseaudio ${sysconfdir}"
-FILES_${PN}-gconf-helper = "${libexecdir}/pulse/gconf-helper"
-FILES_${PN}-misc = "${bindir}/*"
-
-CONFFILES_pulseaudio-server = "\
- ${sysconfdir}/pulse/default.pa \
- ${sysconfdir}/pulse/daemon.conf \
- ${sysconfdir}/pulse/client.conf \
- "
-
-pkg_postinst_${PN}-server() {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- grep -q pulse: /etc/group || addgroup pulse
- grep -q pulse: /etc/passwd || \
- adduser --disabled-password --home=/var/run/pulse --system \
- --ingroup pulse --no-create-home -g "Pulse audio daemon" pulse
- addgroup pulse audio
- /etc/init.d/populate-volatile.sh update
-}
-
-pkg_postrm_${PN}-server() {
- deluser pulse || true
-}
-
-python populate_packages_prepend() {
- #bb.data.setVar('PKG_pulseaudio', 'pulseaudio', d)
-
- plugindir = bb.data.expand('${libdir}/pulse-0.9/modules/', d)
- do_split_packages(d, plugindir, '^module-(.*)\.so$', 'pulseaudio-module-%s', 'PulseAudio module for %s', extra_depends='' )
- do_split_packages(d, plugindir, '^lib(.*)\.so$', 'pulseaudio-lib-%s', 'PulseAudio library for %s', extra_depends='' )
-}
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff
deleted file mode 100644
index 666ed34ad3..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-from upstream svn r2113
-
-Index: configure.ac
-===================================================================
---- configure.ac (wersja 2112)
-+++ configure.ac (wersja 2113)
-@@ -172,6 +172,12 @@
- AC_SUBST(LIBLTDL)
- AC_CONFIG_SUBDIRS(libltdl)
-
-+old_LIBS=$LIBS
-+LIBS="$LIBS $LIBLTDL"
-+AC_CHECK_FUNCS([lt_dlmutex_register])
-+LIBS=$old_LIBS
-+AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
-+
- if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
- AC_MSG_ERROR([[
-
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff
deleted file mode 100644
index cbd82eeb84..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-from upstream svn r2114
-
-Index: configure.ac
-===================================================================
---- configure.ac (wersja 2113)
-+++ configure.ac (wersja 2114)
-@@ -176,7 +176,7 @@
- LIBS="$LIBS $LIBLTDL"
- AC_CHECK_FUNCS([lt_dlmutex_register])
- LIBS=$old_LIBS
--AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
-+AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
-
- if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
- AC_MSG_ERROR([[
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch
deleted file mode 100644
index 4234af5f53..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-upstream: http://pulseaudio.org/ticket/287
-
-Index: pulseaudio-0.9.10/src/Makefile.am
-===================================================================
---- pulseaudio-0.9.10.orig/src/Makefile.am 2008-03-30 03:43:05.000000000 +0200
-+++ pulseaudio-0.9.10/src/Makefile.am 2008-05-03 11:55:46.000000000 +0200
-@@ -605,7 +605,7 @@
-
- libpulsedsp_la_SOURCES = utils/padsp.c
- libpulsedsp_la_CFLAGS = $(AM_CFLAGS)
--libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la
-+libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la libpulsecore.la
- libpulsedsp_la_LDFLAGS = -avoid-version
-
- ###################################
-@@ -888,7 +888,7 @@
-
- libpstream_util_la_SOURCES = pulsecore/pstream-util.c pulsecore/pstream-util.h
- libpstream_util_la_LDFLAGS = -avoid-version
--libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la
-+libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la libpulsecore.la
-
- libpdispatch_la_SOURCES = pulsecore/pdispatch.c pulsecore/pdispatch.h
- libpdispatch_la_LDFLAGS = -avoid-version
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
deleted file mode 100644
index 9e9e5f55d3..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Tell where is libltdl from libtool - was needed to get it built with libtool 2.2.4
-
----
- configure.ac | 26 +++++++++++++++++++-------
- 1 file changed, 19 insertions(+), 7 deletions(-)
-
---- pulseaudio-0.9.10.orig/configure.ac
-+++ pulseaudio-0.9.10/configure.ac
-@@ -242,20 +242,32 @@ if test $ret -eq 0 ; then
- else
- AC_MSG_RESULT([no])
- fi
-
- #### libtool stuff ####
--
--AC_LTDL_ENABLE_INSTALL
--AC_LIBLTDL_INSTALLABLE
--AC_LIBTOOL_DLOPEN
--AC_LIBTOOL_WIN32_DLL
-+LT_PREREQ([2.2])
-+LT_INIT([dlopen win32-dll])
- AC_PROG_LIBTOOL
--AC_SUBST(LTDLINCL)
--AC_SUBST(LIBLTDL)
-+#AC_SUBST(LTDLINCL)
-+#AC_SUBST(LIBLTDL)
- AC_CONFIG_SUBDIRS(libltdl)
-
-+AC_ARG_WITH(libltdl-libs,
-+ [ --with-libltdl-libs=DIR path to libltdl libs], libltdl_libs_prefix=$withval)
-+if test x$libltdl_libs_prefix != x; then
-+ LIBLTDL="-L${libltdl_libs_prefix}/libltdl.so -lltdl"
-+fi
-+AC_SUBST(LIBLTDL)
-+
-+AC_ARG_WITH(libltdl-includes,
-+ [ --with-libltdl-includes=DIR path to libltdl includes], libltdl_prefix=$withval)
-+if test x$libltdl_prefix != x; then
-+ LTDLINCL="-I${libltdl_prefix} ${libltdl_libs_prefix}/libltdl.so"
-+fi
-+AC_SUBST(LTDLINCL)
-+
-+
- old_LIBS=$LIBS
- LIBS="$LIBS $LIBLTDL"
- AC_CHECK_FUNCS([lt_dlmutex_register])
- LIBS=$old_LIBS
- AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch
deleted file mode 100644
index 74ea6ac060..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-upstream: http://pulseaudio.org/changeset/2213
-
-Index: pulseaudio-0.9.10/src/daemon/caps.c
-===================================================================
---- pulseaudio-0.9.10.orig/src/daemon/caps.c 2008-05-03 12:10:26.000000000 +0200
-+++ pulseaudio-0.9.10/src/daemon/caps.c 2008-05-03 12:10:30.000000000 +0200
-@@ -131,9 +131,8 @@
- return 0;
- }
-
--int pa_drop_caps(void) {
-+void pa_drop_caps(void) {
- pa_drop_root();
-- return 0;
- }
-
- #endif
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb b/meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb
deleted file mode 100644
index 671fb66a96..0000000000
--- a/meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-require pulse.inc
-
-DEPENDS += "dbus"
-PR = "r2"
-
-# this is not correct (see below)
-SRC_URI += "\
- file://disable-using-glibc-tls.patch;patch=1 \
- file://libpulsedsp-references-libpulsecore.patch;patch=1 \
- file://pa-drop-caps-returns-void.patch;patch=1 \
- file://2113.diff;patch=1;pnum=0 \
- file://2114.diff;patch=1;pnum=0 \
- file://libtool2.patch;patch=1 \
-"
-
-EXTRA_OECONF += "--with-libltdl-includes=${STAGING_INCDIR}/libltdl/ --with-libltdl-libs=${STAGING_LIBDIR}"
-
-# problems w/ pulseaudio 0.9.10 atm:
-# 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime)
-# 2.) doesn't build w/ glibc TLS support (hence patched out)
-# 3.) fails with hierarchical pthread stuff w/ gst-pulse (hence patched out)