summaryrefslogtreecommitdiffstats
path: root/meta/classes/kernel-arch.bbclass
diff options
context:
space:
mode:
authorJianxun Zhang <jianxun.zhang@linux.intel.com>2016-01-12 13:53:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-15 15:44:37 +0000
commit8d310b24927d0f348fb431895f0583733db2aad0 (patch)
tree2ba8f2fb90e7cfff0701ef82f3ce0b7e3c75f9f7 /meta/classes/kernel-arch.bbclass
parent9a2d4a3b8d7bb1cf7f1fb7fe47d5c002d9941c89 (diff)
downloadopenembedded-core-8d310b24927d0f348fb431895f0583733db2aad0.tar.gz
kernel/kernel-arch: Explicitly mapping between i386/x86_64 and x86 for kernel ARCH
For a bare-bone kernel recipe which specifies 32 bit x86 target, a 64 bit .config will be generated from do_configure task when building 32-bit qemux86, once all of these conditions are true: * arch of host is x86_64 * kernel source tree used in build has commit ffee0de41 which actually chooses i386 or x86_64 defconfig by asking host when ARCH is "x86" (arch/x86/Makefile) * bare-bone kernel recipe inherits directly from kernel without other special treatments. Build will fail because of the mismatched kernel architecture. The patch sets ARCH i386 or x86_64 explicitly to configure task to avoid this host contamination. Kernel artifact is also changed so that it can map i386 and x64 back to arch/x86 when needed. Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/kernel-arch.bbclass')
-rw-r--r--meta/classes/kernel-arch.bbclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/classes/kernel-arch.bbclass b/meta/classes/kernel-arch.bbclass
index 3ed5986a52..d8b180ec49 100644
--- a/meta/classes/kernel-arch.bbclass
+++ b/meta/classes/kernel-arch.bbclass
@@ -21,7 +21,9 @@ def map_kernel_arch(a, d):
valid_archs = d.getVar('valid_archs', True).split()
- if re.match('(i.86|athlon|x86.64)$', a): return 'x86'
+ if re.match('i.86$', a): return 'i386'
+ elif re.match('x86.64$', a): return 'x86_64'
+ elif re.match('athlon$', a): return 'x86'
elif re.match('armeb$', a): return 'arm'
elif re.match('aarch64$', a): return 'arm64'
elif re.match('aarch64_be$', a): return 'arm64'