summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools3.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-08 14:30:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-09 11:46:23 +0000
commit12857a77ad424c3c3cbc37275374a603e528d9f1 (patch)
treededf82795d9509560ca60bf3805ebd8f6c16b331 /meta/classes/setuptools3.bbclass
parentec8799eb92174cb6780a0cc7e1fa9828e4d75c79 (diff)
downloadopenembedded-core-12857a77ad424c3c3cbc37275374a603e528d9f1.tar.gz
setuptools3: respect PIP_INSTALL_DIST_PATH
pip_install_wheel expects the wheels to be in PIP_INSTALL_DIST_PATH but this class was writing to the same directory through chance not design. Respect PIP_INSTALL_DIST_PATH as the output directory. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/setuptools3.bbclass')
-rw-r--r--meta/classes/setuptools3.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index 1b1a8aac76..dcf3561b8d 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -17,11 +17,11 @@ setuptools3_do_compile() {
STAGING_INCDIR=${STAGING_INCDIR} \
STAGING_LIBDIR=${STAGING_LIBDIR} \
${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
- bdist_wheel --verbose ${SETUPTOOLS_BUILD_ARGS} || \
+ bdist_wheel --verbose --dist-dir ${PIP_INSTALL_DIST_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed."
}
setuptools3_do_compile[vardepsexclude] = "MACHINE"
-do_compile[cleandirs] += "${SETUPTOOLS_SETUP_PATH}/dist"
+do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"
setuptools3_do_install() {
pip_install_wheel_do_install