summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools3.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-11 12:03:02 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-13 12:21:07 +0000
commit3bdf64b97facce9706cc579bdbc9a80e0d48428f (patch)
tree87250844be228d473eb8484324c5cbb70735c38a /meta/classes/setuptools3.bbclass
parent15baf24f750ab2c8b0a46d4a3bf2ae9bfa3d0aff (diff)
downloadopenembedded-core-3bdf64b97facce9706cc579bdbc9a80e0d48428f.tar.gz
meta: rename pip_install_wheel.bbclass to python_pep517.bbclass
pip_install_wheel shouldn't restricted to just using Pip to install wheels (the installer module is simplier and likely a better option), and in the future may be extended to also provide do_compile() using the build module. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/setuptools3.bbclass')
-rw-r--r--meta/classes/setuptools3.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/setuptools3.bbclass b/meta/classes/setuptools3.bbclass
index dcf3561b8d..556bc801af 100644
--- a/meta/classes/setuptools3.bbclass
+++ b/meta/classes/setuptools3.bbclass
@@ -1,4 +1,4 @@
-inherit setuptools3-base pip_install_wheel
+inherit setuptools3-base python_pep517
# bdist_wheel builds in ./dist
#B = "${WORKDIR}/build"
@@ -17,14 +17,14 @@ setuptools3_do_compile() {
STAGING_INCDIR=${STAGING_INCDIR} \
STAGING_LIBDIR=${STAGING_LIBDIR} \
${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
- bdist_wheel --verbose --dist-dir ${PIP_INSTALL_DIST_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
+ bdist_wheel --verbose --dist-dir ${PEP517_WHEEL_PATH} ${SETUPTOOLS_BUILD_ARGS} || \
bbfatal_log "'${PYTHON_PN} setup.py bdist_wheel ${SETUPTOOLS_BUILD_ARGS}' execution failed."
}
setuptools3_do_compile[vardepsexclude] = "MACHINE"
-do_compile[cleandirs] += "${PIP_INSTALL_DIST_PATH}"
+do_compile[cleandirs] += "${PEP517_WHEEL_PATH}"
setuptools3_do_install() {
- pip_install_wheel_do_install
+ python_pep517_do_install
}
EXPORT_FUNCTIONS do_configure do_compile do_install