summaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-13 09:41:25 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-15 13:46:06 +0100
commit23363c990c3d1a485fa6f3c7a77ccc58bf325d1d (patch)
tree1c1b6a476e4dfc3f52e120f0d7ef091fdde77d8a /meta/classes
parent2295705918707992705b5df4e4c17cb4cf5a3df5 (diff)
downloadopenembedded-core-23363c990c3d1a485fa6f3c7a77ccc58bf325d1d.tar.gz
insane.class: print the recipe name in the warning.
Now Warning includes the package name like zlib is printed bellow: WARNING: zlib: Recipe file does not have license file information (LIC_FILES_CHKSUM) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/insane.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 6b14f90027..b7ab98d34f 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -343,11 +343,12 @@ def package_qa_check_license(workdir, d):
sane = True
lic_files = bb.data.getVar('LIC_FILES_CHKSUM', d, True)
+ pn = bb.data.getVar('PN', d, True)
if not lic_files:
# just throw a warning now. Once licensing data in entered for enough of the recipes,
# this will be converted into error and False will be returned.
- bb.warn(" Recipe (.bb) file does not have license file information (LIC_FILES_CHKSUM)")
+ bb.warn(pn + ": Recipe file does not have license file information (LIC_FILES_CHKSUM)")
return True
srcdir = bb.data.getVar('S', d, True)