summaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-06-28 11:02:45 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:19:05 +0100
commit4057e1a81132ac39a36af0b6b91ae29a873fa6fd (patch)
tree7847aeae7104f87634582a72b6931bd8bf0266b7 /meta/classes
parent3b78d2e0a2631c703fac7f3f9a33f2359cb35956 (diff)
downloadopenembedded-core-4057e1a81132ac39a36af0b6b91ae29a873fa6fd.tar.gz
insane.bbclass: allow reporting all md5 mismatch warnings
instead of exiting when once one md5 mismatch is seen. This would be helpful to save time on filling md5sum for multiple license check files. Signed-off-by Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/insane.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 0511717c94..230a1be752 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -326,7 +326,7 @@ def package_qa_check_license(workdir, d):
bb.error ("md5 data is not matching for ", url)
bb.note ("The new md5 checksum is ", md5chksum)
bb.note ("Check if the license information has changed, and if it has update the .bb file with correct license")
- return False
+ sane = False
return sane