summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups
diff options
context:
space:
mode:
authorPeter Bergin <peter@berginkonsult.se>2022-08-23 10:56:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-03 08:51:32 +0100
commit1de29eb5ec091427560e1f0b6b16c91a3a994835 (patch)
treeb9dcbea8c54a3457508e958eb14b04890234a461 /meta/recipes-core/packagegroups
parentd30eb681f41bf9e921f7f0d42747fff7a4be9229 (diff)
downloadopenembedded-core-1de29eb5ec091427560e1f0b6b16c91a3a994835.tar.gz
packagegroup-rust-cross-canadian: add native compiler environment
When building rust crates it is quite common to have a build script [1] that is compiled for the host machine and then used during build for target. Currently when adding packagegroup-rust-cross-canadian this does not work without having the native compiler and linker added to the SDK. Add those packages to the packagegroup to make it easier to handle. The reason for having glibc-dev and libgcc-dev is to have version match with the used tools. Otherwise it will work on hosts that have compatible gcc and glibc versions but not on all. [1] https://doc.rust-lang.org/cargo/reference/build-scripts.html Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb b/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb
index 42f85f0eb3..bb10a2d34f 100644
--- a/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb
@@ -9,6 +9,10 @@ RUST="rust-cross-canadian-${TRANSLATED_TARGET_ARCH}"
RDEPENDS:${PN} = " \
${@all_multilib_tune_values(d, 'RUST')} \
+ nativesdk-binutils \
+ nativesdk-gcc \
+ nativesdk-glibc-dev \
+ nativesdk-libgcc-dev \
nativesdk-rust \
nativesdk-cargo \
nativesdk-rust-tools-clippy \