summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c
diff options
context:
space:
mode:
authorhongxu <hongxu.jia@windriver.com>2021-08-04 21:08:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-05 08:51:17 +0100
commit54368f1b02e1ac4aa068515730a8c8bcd3683eb3 (patch)
tree4c4a329fee1fcd3b943871ba5bef919885d7d065 /meta/recipes-devtools/createrepo-c
parent41bff44bd26c09573eb3139bb6735e5ecfda18b7 (diff)
downloadopenembedded-core-54368f1b02e1ac4aa068515730a8c8bcd3683eb3.tar.gz
createrepo-c: fix createrepo-c failed in nativesdk
In sdk, call createrepo-c failed with: ... $ createrepo_c --update ./test_repo/rpm Directory walk started Critical: Failed to detect compression for file ./test_repo/rpm/cortexa72/hello-2.10-r0.cortexa72.rpm: magic_load() failed: could not find any valid magic files! ... Since commit [ea666fbc74 createrepo-c: set path to magic database for native and nativesdk] applied, the MAGIC is incorrectly assigned. The variable datadir will be expanded automatically for nativesdk, do not need to add prefix ${SDKPATHNATIVE} to MAGIC Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
index 6313afc108..500b508d72 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
@@ -33,8 +33,8 @@ do_install:append:class-native() {
do_install:append:class-nativesdk() {
create_wrapper ${D}/${bindir}/createrepo_c \
RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
- MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ MAGIC=${datadir}/misc/magic.mgc
create_wrapper ${D}/${bindir}/modifyrepo_c \
- MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ MAGIC=${datadir}/misc/magic.mgc
rm -rf ${D}/etc
}