summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c
diff options
context:
space:
mode:
authorDiego Santa Cruz <Diego.SantaCruz@spinetix.com>2021-02-26 12:33:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-27 22:40:36 +0000
commitea666fbc74163e7ef27a52a072b75fd1f5ac5c25 (patch)
tree6fcdc3ce1afb51e30107b45f3ea26a3d4649bd32 /meta/recipes-devtools/createrepo-c
parentaac00b1c8042e41cd6bb1aea8e3033a1c6dd2b05 (diff)
downloadopenembedded-core-ea666fbc74163e7ef27a52a072b75fd1f5ac5c25.tar.gz
createrepo-c: set path to magic database for native and nativesdk
The modifyrepo_c tool can use the magic database for input files (e.g., if the file has no recognized extension) and fails if none can be found. This adds a wrapper that sets MAGIC to point to the proper place, it also sets up MAGIC in the createrepo_c wrapper since that tool also takes input files. Signed-off-by: Diego Santa Cruz <Diego.SantaCruz@spinetix.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
index 350b183542..e0433806b2 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
@@ -24,11 +24,17 @@ BBCLASSEXTEND = "native nativesdk"
# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
do_install_append_class-native() {
create_wrapper ${D}/${bindir}/createrepo_c \
- RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
+ RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
+ create_wrapper ${D}/${bindir}/modifyrepo_c \
+ MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
}
do_install_append_class-nativesdk() {
create_wrapper ${D}/${bindir}/createrepo_c \
- RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
+ MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ create_wrapper ${D}/${bindir}/modifyrepo_c \
+ MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
rm -rf ${D}/etc
}