summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/docbook-utils
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 11:05:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 12:44:36 +0100
commit2b190155d74d4369c61d26b1f4f0c3cce389ddbc (patch)
tree2d28af443bf08b822562f82b33ede17a4452e67c /meta/recipes-devtools/docbook-utils
parentc9dcfbd87d749baa0a4948738055193982aad26d (diff)
downloadopenembedded-core-2b190155d74d4369c61d26b1f4f0c3cce389ddbc.tar.gz
docbook-utils-native: Fix re-execution of the unpack task
If the do_unpack task is re-executed, the sed_done stamp was not removed, the sed commands wouldn't re-run and the build would fail in do_compile. This patch ensures the stamp is in ${S} and that we clean that directory when unpack runs so it is a build from sctatch at that point. [YOCTO #2194] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/docbook-utils')
-rw-r--r--meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
index 2a894796ae..5e1384d588 100644
--- a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
+++ b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
@@ -21,16 +21,17 @@ inherit autotools native
do_configure_prepend() {
# Fix hard-coded references to /etc/sgml
- if [ ! -e ${WORKDIR}/.sed_done ]; then
+ if [ ! -e ${S}/.sed_done ]; then
sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
# Point jw to the native sysroot catalog
sed -i -e 's|^SGML_EXTRA_CATALOGS=""|SGML_EXTRA_CATALOGS=":${sysconfdir}/sgml/catalog"|g' bin/jw.in
- touch ${WORKDIR}/.sed_done
+ touch ${S}/.sed_done
fi
}
+do_unpack[cleandirs] += "${S}"
do_install() {
install -d ${D}${bindir}