summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.176.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-01 16:37:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-02 09:56:14 +0100
commit7ff76b86299289a4a5741f910399d95232f64f32 (patch)
treeaa4f994529cc7b63f4919ed1c6f748d669937ce0 /meta/recipes-devtools/elfutils/elfutils_0.176.bb
parent1aa947a60b0eb31c367b1e9818218ee74d388eea (diff)
downloadopenembedded-core-7ff76b86299289a4a5741f910399d95232f64f32.tar.gz
elfutils: ptest fixes
Changes to improve the way ptest runs: a) Use the standalone test mode which allows the tests to be run in their 'installled' locations on target (but not any of the standalone build pieces) b) We want to use the binaries from their installed locations so the run-subr script needs tweaking to run them like that. The rpath conditional isn't enough since we want the second entry in the case statement. c) Add an oecheck make target which we can use to build the test binaries we need d) Add missing -ptest package dependencies (needs coreutils, ${PN}, ${PN}-binutils, make) e) Don't add RPATH to the test binaries, we don't need that f) Add some extra parameters to the make command to ensure tests run correctly Before: ----------------------------------------------------- Recipe | Passed | Failed | Skipped | Time(s) ----------------------------------------------------- elfutils | 31 | 4 | 168 | 6 ----------------------------------------------------- After: ----------------------------------------------------- Recipe | Passed | Failed | Skipped | Time(s) ----------------------------------------------------- elfutils | 173 | 25 | 5 | 15 ----------------------------------------------------- Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.176.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.176.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.176.bb b/meta/recipes-devtools/elfutils/elfutils_0.176.bb
index fb2868723a..19d27cd992 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.176.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.176.bb
@@ -30,7 +30,7 @@ SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
file://debian/testsuite-ignore-elflint.diff \
file://0001-skip-the-test-when-gcc-not-deployed.patch \
file://run-ptest \
- file://serial-tests.patch \
+ file://ptest.patch \
"
SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch \
file://0001-fix-err-variable-and-function-conflicts.patch \
@@ -43,10 +43,9 @@ inherit autotools gettext ptest
EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
EXTRA_OECONF_append_class-native = " --without-bzlib"
-# gcc has been added to blacklist, we will find workaround solution
-RDEPENDS_${PN}-ptest = "libasm libelf bash"
+RDEPENDS_${PN}-ptest = "libasm libelf bash make coreutils ${PN}-binutils ${PN}"
-EXTRA_OECONF_append_class-target += "--enable-tests-rpath"
+EXTRA_OECONF_append_class-target += "--disable-tests-rpath"
do_install_append() {
if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
@@ -56,14 +55,13 @@ do_install_append() {
do_compile_ptest() {
cd ${B}/tests
- oe_runmake buildtest-TESTS
+ oe_runmake buildtest-TESTS oecheck
}
do_install_ptest() {
if [ ${PTEST_ENABLED} = "1" ]; then
cp -r ${S}/tests/ ${D}${PTEST_PATH}
cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests
- cp -r ${B}/src ${D}${PTEST_PATH}
cp -r ${B}/config.h ${D}${PTEST_PATH}
cp -r ${B}/backends ${D}${PTEST_PATH}
sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile