summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_7.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-14 18:10:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-14 10:23:21 +0100
commit03bb12008891cf1a023aaddb6547da6d41d0cab0 (patch)
treec778022d8ecf55bacfa0a92ac7245eeb194d2147 /meta/recipes-devtools/gcc/gcc_7.1.bb
parent835b705ee92900f0d73cee612ce790fde4b1e2a4 (diff)
downloadopenembedded-core-03bb12008891cf1a023aaddb6547da6d41d0cab0.tar.gz
gcc: Add recipes for gcc-7
Switch default compiler to gcc 7 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_7.1.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_7.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_7.1.bb b/meta/recipes-devtools/gcc/gcc_7.1.bb
new file mode 100644
index 0000000000..2c618dfb93
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_7.1.bb
@@ -0,0 +1,9 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require gcc-target.inc
+
+# Building with thumb enabled on armv4t fails with
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
+ARM_INSTRUCTION_SET_armv4 = "arm"
+
+BBCLASSEXTEND = "nativesdk"