summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-11 22:21:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-15 14:37:35 +0000
commit25627fb304bbd26d994f68e29fb18802144149b2 (patch)
treef4cbe6061d01d6fdd3d057cd14d29d7f60525dff /meta/recipes-devtools/go
parent06ac55a06f2300fa5442ec73a28c3f52022cc640 (diff)
downloadopenembedded-core-25627fb304bbd26d994f68e29fb18802144149b2.tar.gz
go: Update to 1.16.2
This is bugfix release in 1.16 series [1] [1] https://golang.org/doc/devel/release.html#go1.16.minor Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go')
-rw-r--r--meta/recipes-devtools/go/go-1.16.2.inc (renamed from meta/recipes-devtools/go/go-1.16.inc)4
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.16.2.bb (renamed from meta/recipes-devtools/go/go-binary-native_1.16.bb)4
-rw-r--r--meta/recipes-devtools/go/go-cross-canadian_1.16.2.bb (renamed from meta/recipes-devtools/go/go-cross-canadian_1.16.bb)0
-rw-r--r--meta/recipes-devtools/go/go-cross_1.16.2.bb (renamed from meta/recipes-devtools/go/go-cross_1.16.bb)0
-rw-r--r--meta/recipes-devtools/go/go-crosssdk_1.16.2.bb (renamed from meta/recipes-devtools/go/go-crosssdk_1.16.bb)0
-rw-r--r--meta/recipes-devtools/go/go-native_1.16.2.bb (renamed from meta/recipes-devtools/go/go-native_1.16.bb)0
-rw-r--r--meta/recipes-devtools/go/go-runtime_1.16.2.bb (renamed from meta/recipes-devtools/go/go-runtime_1.16.bb)0
-rw-r--r--meta/recipes-devtools/go/go_1.16.2.bb (renamed from meta/recipes-devtools/go/go_1.16.bb)0
8 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/go/go-1.16.inc b/meta/recipes-devtools/go/go-1.16.2.inc
index 1ebbbef833..e65caf8197 100644
--- a/meta/recipes-devtools/go/go-1.16.inc
+++ b/meta/recipes-devtools/go/go-1.16.2.inc
@@ -1,7 +1,7 @@
require go-common.inc
GO_BASEVERSION = "1.16"
-PV = "1.16"
+PV = "1.16.2"
FILESEXTRAPATHS_prepend := "${FILE_DIRNAME}/go-${GO_BASEVERSION}:"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
@@ -17,4 +17,4 @@ SRC_URI += "\
file://0008-use-GOBUILDMODE-to-set-buildmode.patch \
file://0009-Revert-cmd-go-make-sure-CC-and-CXX-are-absolute.patch \
"
-SRC_URI[main.sha256sum] = "7688063d55656105898f323d90a79a39c378d86fe89ae192eb3b7fc46347c95a"
+SRC_URI[main.sha256sum] = "37ca14287a23cb8ba2ac3f5c3dd8adbc1f7a54b9701a57824bf19a0b271f83ea"
diff --git a/meta/recipes-devtools/go/go-binary-native_1.16.bb b/meta/recipes-devtools/go/go-binary-native_1.16.2.bb
index 155a475c95..4fb060173c 100644
--- a/meta/recipes-devtools/go/go-binary-native_1.16.bb
+++ b/meta/recipes-devtools/go/go-binary-native_1.16.2.bb
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
PROVIDES = "go-native"
SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
-SRC_URI[go_linux_amd64.sha256sum] = "013a489ebb3e24ef3d915abe5b94c3286c070dfe0818d5bca8108f1d6e8440d2"
-SRC_URI[go_linux_arm64.sha256sum] = "3770f7eb22d05e25fbee8fb53c2a4e897da043eb83c69b9a14f8d98562cd8098"
+SRC_URI[go_linux_amd64.sha256sum] = "542e936b19542e62679766194364f45141fde55169db2d8d01046555ca9eb4b8"
+SRC_URI[go_linux_arm64.sha256sum] = "6924601d998a0917694fd14261347e3798bd2ad6b13c4d7f2edd70c9d57f62ab"
UPSTREAM_CHECK_URI = "https://golang.org/dl/"
UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
diff --git a/meta/recipes-devtools/go/go-cross-canadian_1.16.bb b/meta/recipes-devtools/go/go-cross-canadian_1.16.2.bb
index 7ac9449e47..7ac9449e47 100644
--- a/meta/recipes-devtools/go/go-cross-canadian_1.16.bb
+++ b/meta/recipes-devtools/go/go-cross-canadian_1.16.2.bb
diff --git a/meta/recipes-devtools/go/go-cross_1.16.bb b/meta/recipes-devtools/go/go-cross_1.16.2.bb
index 80b5a03f6c..80b5a03f6c 100644
--- a/meta/recipes-devtools/go/go-cross_1.16.bb
+++ b/meta/recipes-devtools/go/go-cross_1.16.2.bb
diff --git a/meta/recipes-devtools/go/go-crosssdk_1.16.bb b/meta/recipes-devtools/go/go-crosssdk_1.16.2.bb
index 1857c8a577..1857c8a577 100644
--- a/meta/recipes-devtools/go/go-crosssdk_1.16.bb
+++ b/meta/recipes-devtools/go/go-crosssdk_1.16.2.bb
diff --git a/meta/recipes-devtools/go/go-native_1.16.bb b/meta/recipes-devtools/go/go-native_1.16.2.bb
index f14892cdb0..f14892cdb0 100644
--- a/meta/recipes-devtools/go/go-native_1.16.bb
+++ b/meta/recipes-devtools/go/go-native_1.16.2.bb
diff --git a/meta/recipes-devtools/go/go-runtime_1.16.bb b/meta/recipes-devtools/go/go-runtime_1.16.2.bb
index 63464a1501..63464a1501 100644
--- a/meta/recipes-devtools/go/go-runtime_1.16.bb
+++ b/meta/recipes-devtools/go/go-runtime_1.16.2.bb
diff --git a/meta/recipes-devtools/go/go_1.16.bb b/meta/recipes-devtools/go/go_1.16.2.bb
index 4e9e0ebec8..4e9e0ebec8 100644
--- a/meta/recipes-devtools/go/go_1.16.bb
+++ b/meta/recipes-devtools/go/go_1.16.2.bb