summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.11.08.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-28 01:51:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-29 14:39:00 +0100
commit0ebf49f56571d5e1951d47f479ab9713442e30bc (patch)
tree826cbd4f2c61f27b7ba70bda76c1a5ee5a5aec57 /meta/recipes-devtools/nasm/nasm_2.11.08.bb
parent9c5cb4e2b51e605523d636f57d071593a01014ee (diff)
downloadopenembedded-core-0ebf49f56571d5e1951d47f479ab9713442e30bc.tar.gz
nasm: 2.11.06 -> 2.11.08
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.11.08.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.11.08.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.11.08.bb b/meta/recipes-devtools/nasm/nasm_2.11.08.bb
new file mode 100644
index 0000000000..e0724e68ad
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.11.08.bb
@@ -0,0 +1,30 @@
+SUMMARY = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
+COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
+
+
+SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
+
+SRC_URI[md5sum] = "7aae5cb8e03fac48029c82a7470ab066"
+SRC_URI[sha256sum] = "9da3a0291a0bdc06305b7ba194f1e2c2b55ae6f11210b4af43729868149d5445"
+
+inherit autotools-brokensep
+
+do_configure_prepend () {
+ if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "groff-native"