summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 02:05:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:17:39 +0000
commit1f7583d669f1d13cdc2ed0f7c468c65879489cca (patch)
treecd0f33fa211b75c265ec8f64a3581ddf50f63033 /meta/recipes-devtools/nasm
parent97dc39e42e95dcadc7bed1aee32db3560e21efe5 (diff)
downloadopenembedded-core-1f7583d669f1d13cdc2ed0f7c468c65879489cca.tar.gz
nasm: Fix case where ${B} != ${S} (partial)
Fix out of tree build by fixing cwd assumptions. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.07.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.07.bb b/meta/recipes-devtools/nasm/nasm_2.10.07.bb
index 1c95ed82bc..bcecce4a81 100644
--- a/meta/recipes-devtools/nasm/nasm_2.10.07.bb
+++ b/meta/recipes-devtools/nasm/nasm_2.10.07.bb
@@ -13,8 +13,8 @@ SRC_URI[sha256sum] = "c056e2abc83816892e448f9e9e95a3d21e9e096f44341b9d4853f62a44
inherit autotools
do_configure_prepend () {
- if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
- mv aclocal.m4 acinclude.m4
+ if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
+ mv ${S}/aclocal.m4 ${S}/acinclude.m4
fi
}