summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/files
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-17 22:40:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:53:52 +0100
commit9260c1b9d04a88d15ab5376c7cd56f381fe3e53b (patch)
tree3d89f2f743eb1d421feeab38b3a70b291593b4d8 /meta/recipes-devtools/perl/files
parenta539f1f00441dbb29af215082ba0c7c78fb0eaa1 (diff)
downloadopenembedded-core-9260c1b9d04a88d15ab5376c7cd56f381fe3e53b.tar.gz
perl-native_5.12.2.bb: Fix compliation on ubuntu 11.04-alpha
Ubuntu has moved eglibc to /usr/lib/${arch}-linux-gnu and /lib/${arch}-linux-gnu so we need that to be added to glibpth in Configure. Currently we set LD=ld in environment for recipes inheriting native class. This overrides the LD settings in the Makefiles of perl and it tries to link by calling ld which does not work since its using -l<x> on commandline and ubuntu linker seems not to look into the new location for these libraries. Its better to use gcc for linking here anyway [With tweak from Tom Rini to use CCLD, not LD] (From OE-Core rev: 8ba700a4c593fd52bd01b6272b4c8285a71964f7) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Further tweaks to Configure-multilib.patch for x86_64 vs x86 from Gary Thomas Cc: gary@mlbassoc.com Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/files')
-rw-r--r--meta/recipes-devtools/perl/files/Configure-multilib.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/files/Configure-multilib.patch b/meta/recipes-devtools/perl/files/Configure-multilib.patch
new file mode 100644
index 0000000000..545a8b821d
--- /dev/null
+++ b/meta/recipes-devtools/perl/files/Configure-multilib.patch
@@ -0,0 +1,15 @@
+Index: perl-5.12.2/Configure
+===================================================================
+--- perl-5.12.2.orig/Configure
++++ perl-5.12.2/Configure
+@@ -1316,8 +1316,9 @@ loclibpth="/usr/local/lib /opt/local/lib
+ loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
+
+ : general looking path for locating libraries
+-glibpth="/lib /usr/lib $xlibpth"
++glibpth="/lib /usr/lib /lib64 /usr/lib64 $xlibpth"
+ glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
++test -f /usr/lib/*-linux-gnu/libc.so && glibpth="/usr/lib/*-linux-gnu $glibpth"
+ test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
+ test -f /shlib/libc.so && glibpth="/shlib $glibpth"
+ test -d /usr/lib64 && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"