summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-04 15:24:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-05 11:52:15 +0000
commit846ff49465337dddd75a83161f41f48117f6571c (patch)
tree3c57e9f8819cf77a9a6ce988d0046670eb1f06e5 /meta/recipes-devtools/perl
parent6a4f24724cea3ddf55cacccb80fa54aa898dfa86 (diff)
downloadopenembedded-core-846ff49465337dddd75a83161f41f48117f6571c.tar.gz
recipes/classes: Drop prepend/append usage with PACKAGESPLITFUNCS
As far as I can tell, none of these uses of PACKAGESPLITFUNCS need append/prepend operators, the standard += and =+ can work just fine. Since OE-Core is copied a lot, use the preferred syntax which is also simpler to parse and change. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl_5.36.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.36.0.bb b/meta/recipes-devtools/perl/perl_5.36.0.bb
index 2dc558aaa5..3458e6a5b0 100644
--- a/meta/recipes-devtools/perl/perl_5.36.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.36.0.bb
@@ -302,7 +302,7 @@ ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3"
ALLOW_EMPTY:${PN}-modules = "1"
PACKAGES += "${PN}-modules "
-PACKAGESPLITFUNCS:prepend = "split_perl_packages "
+PACKAGESPLITFUNCS =+ "split_perl_packages "
python split_perl_packages () {
libdir = d.expand('${libdir}/perl5/${PV}')