summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-13 09:54:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-20 14:06:31 +0000
commit6a320d07e45d9c41a6b50b96ba7f910cc141a1dd (patch)
treefb106acfe82fc62cdb955f079a28b8a8e4dc19df /meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
parent104990923f82d129a0fc8e6cd5bf0224751d5d03 (diff)
downloadopenembedded-core-6a320d07e45d9c41a6b50b96ba7f910cc141a1dd.tar.gz
postinst-intercept: rename recipe for nativesdk only
The recipe postinst-intercept is only used for nativesdk, so we rename it from postinst-intercept to nativesdk-postinst-intercept. It avoids unnecessary build of postinst-intercept. [YOCTO #6937] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb')
-rw-r--r--meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb b/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
new file mode 100644
index 0000000000..7dc45c68f2
--- /dev/null
+++ b/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Postinstall scriptlets"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+FILES_${PN}_append = " ${datadir}/postinst-intercepts/*"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${datadir}/postinst-intercepts
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/postinst_intercept ${D}${datadir}/postinst-intercepts/
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_font_cache ${D}${datadir}/postinst-intercepts/
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_icon_cache ${D}${datadir}/postinst-intercepts/
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_pixbuf_cache ${D}${datadir}/postinst-intercepts/
+}
+
+inherit nativesdk
+INHIBIT_DEFAULT_DEPS = "1"