summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 10:47:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 12:44:36 +0100
commit1d8c40d5f2119b4c4ae8a9b2645ae572ea9a54ff (patch)
tree98070a4c9ce27475218072571195ff30bdbfb84c /meta/recipes-devtools/python/python-native
parente7135f14f3ef37f93f5c28b319464f3d6dd9b8da (diff)
downloadopenembedded-core-1d8c40d5f2119b4c4ae8a9b2645ae572ea9a54ff.tar.gz
python: Fix re-execution problem due to patching configure and configure.in
There was a patch patching both configure and configure.in. Since the recipes all autoreconf, this is pointless and means subsequent patch tasks fail. The fix is to only patch configure.in. [YOCTO #2194] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native')
-rw-r--r--meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch11
1 files changed, 0 insertions, 11 deletions
diff --git a/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch b/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
index ed529366c5..1cb8fea50f 100644
--- a/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
+++ b/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
@@ -14,17 +14,6 @@ Issue #12326: sys.platform is now always 'linux2' on Linux
Even if Python is compiled on Linux 3.
-diff --git a/configure b/configure
---- a/configure
-+++ b/configure
-@@ -2995,6 +2995,7 @@ then
- MACHDEP="$ac_md_system$ac_md_release"
-
- case $MACHDEP in
-+ linux*) MACHDEP="linux2";;
- cygwin*) MACHDEP="cygwin";;
- darwin*) MACHDEP="darwin";;
- atheos*) MACHDEP="atheos";;
diff --git a/configure.in b/configure.in
--- a/configure.in
+++ b/configure.in