summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-21 20:39:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-22 22:21:12 +0100
commit1c7f6f444fdcb859a37d3b51a8d47260834d01db (patch)
tree09953062572dc6fe2d781cc7dfe6fd02c0cdaf62 /meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb
parentca0039a6e5524ab1e74df285ce16460dc980da65 (diff)
downloadopenembedded-core-1c7f6f444fdcb859a37d3b51a8d47260834d01db.tar.gz
python3-hypothesis: enable ptest
The upstream "fast" tests (tests/cover and tests/pytest) take over 5 minutes to run and do not run cleanly. They also add dependency on python3-pexpect and python3-ptyprocess (currently in meta-python). The tests are also not included in the pypi tarball, so it would require use of git fetcher and other invasive changes to the recipe, including dropping the pypi inherit. Instead, use two test suites from examples/ References: https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python/tests https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python/examples Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb b/meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb
index 9f0b7eaf3d..1ea6bb56e6 100644
--- a/meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.15.0.bb
@@ -5,7 +5,13 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
PYPI_PACKAGE = "hypothesis"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+ file://test_binary_search.py \
+ file://test_rle.py \
+ "
SRC_URI[sha256sum] = "10699f595eebb9410fd902908aa13aece19be5c437b405092be34f60f69f7999"
@@ -19,4 +25,14 @@ RDEPENDS:${PN} += " \
python3-unittest \
"
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ "
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/examples
+ install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
+ install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
+}
+
BBCLASSEXTEND = "native nativesdk"