summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-28 22:32:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-29 21:21:27 +0000
commit995a0421ab39d62354e56f77eca10e2d176582d4 (patch)
tree94a80b5e5e6b305e88fbb25f0e1b3d81a7e7999b /meta/recipes-devtools/ruby
parente8c0012ea036cb962db25a5941619c22e7218985 (diff)
downloadopenembedded-core-995a0421ab39d62354e56f77eca10e2d176582d4.tar.gz
ruby: Fix to work with autoconf 2.70
Drop a macro we don't need which was breaking with autoconf 2.70. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby')
-rw-r--r--meta/recipes-devtools/ruby/ruby/autoconf270.patch34
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.7.2.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby/autoconf270.patch b/meta/recipes-devtools/ruby/ruby/autoconf270.patch
new file mode 100644
index 0000000000..8d205bde43
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby/autoconf270.patch
@@ -0,0 +1,34 @@
+This macro breaks under autoconf 2.70. Since we don't worry abot darwin or
+openbsd builds, simply remove it.
+
+Upstream-Status: Pending
+RP - 2021/1/28
+
+Index: ruby-2.7.2/configure.ac
+===================================================================
+--- ruby-2.7.2.orig/configure.ac
++++ ruby-2.7.2/configure.ac
+@@ -170,23 +170,6 @@ dnl orig_cxxflags="$cxxflags"
+ dnl cxxflags="$cxxflags "'${optflags} ${debugflags} ${warnflags}'
+ dnl ])
+
+-AS_CASE(["$host_os:$build_os"],
+-[darwin*:darwin*], [
+- AC_CHECK_TOOLS(CC, [clang gcc cc])
+- # Following Apple deployed clang are broken
+- # clang version 1.0 (http://llvm.org/svn/llvm-project/cfe/tags/Apple/clang-23 exported)
+- # Apple clang version 2.0 (tags/Apple/clang-137) (based on LLVM 2.9svn)
+- # Apple clang version 2.1 (tags/Apple/clang-163.7.1) (based on LLVM 3.0svn)
+- AS_IF([! $CC -E -xc - <<SRC >/dev/null], [
+- @%:@if defined __APPLE_CC__ && defined __clang_major__ && __clang_major__ < 3
+- @%:@error premature clang
+- @%:@endif
+-SRC
+- AC_MSG_ERROR([clang version 3.0 or later is required])
+- ])],
+-[openbsd*:openbsd*], [
+- AC_CHECK_TOOLS(CC, [cc])
+-])
+ AS_IF([test x"${build}" != x"${host}"], [
+ AC_CHECK_TOOL(CC, gcc)
+ ])
diff --git a/meta/recipes-devtools/ruby/ruby_2.7.2.bb b/meta/recipes-devtools/ruby/ruby_2.7.2.bb
index db6d672985..8c338ebecf 100644
--- a/meta/recipes-devtools/ruby/ruby_2.7.2.bb
+++ b/meta/recipes-devtools/ruby/ruby_2.7.2.bb
@@ -7,6 +7,7 @@ SRC_URI += " \
file://run-ptest \
file://0001-Modify-shebang-of-libexec-y2racc-and-libexec-racc2y.patch \
file://0001-template-Makefile.in-do-not-write-host-cross-cc-item.patch \
+ file://autoconf270.patch \
"
SRC_URI[md5sum] = "2d4a28dcfa38352a627a597f6057c465"