summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools
diff options
context:
space:
mode:
authorNisha Parrakat <nishaparrakat@gmail.com>2021-05-26 20:03:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-27 13:20:44 +0100
commit543c3042eb5c79c6d506262c5d5d36884358d0be (patch)
treeea9096d52020693cff38f47899d626c5da563a24 /meta/recipes-devtools/squashfs-tools
parent61947fc024bf18b42547d2ea4cad90184132994d (diff)
downloadopenembedded-core-543c3042eb5c79c6d506262c5d5d36884358d0be.tar.gz
squashfs-tools: package squashfs-fs.h
Needed to build the latest debian version of android-tools Fixes below error while building android-tools libext4_utils.mk | squashfs_utils/squashfs_utils.c:27:10: fatal error: 'squashfs_fs.h' file not found | #include "squashfs_fs.h" | ^~~~~~~~~~~~~~~ | 1 error generated. | core2-64-poky-linux/android-tools/10.0.0.r36-r0/git/system/extras/debian/libext4_utils.mk:29: recipe for target 'build' failed | make: *** [build] Error 1 Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com> Signed-off-by: Nisha Parrakat <nishaparrakat@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
index 2b1409d78d..137e5097fa 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
@@ -32,7 +32,9 @@ do_compile() {
}
do_install() {
+ install -d "${D}${includedir}"
oe_runmake install INSTALL_DIR=${D}${sbindir}
+ install -m 0644 "${S}"/squashfs_fs.h "${D}${includedir}"
}
ARM_INSTRUCTION_SET_armv4 = "arm"