summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-10-18 12:52:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-31 16:07:11 +0000
commit6f65dd3164a6f523de82cb30e67ec3d180e45c2e (patch)
tree688c035952f7ba804768aab4f0caa787932c7578 /meta/recipes-devtools/squashfs-tools
parent73a1e1135618a23f3f2a714c311df39c7b809ed5 (diff)
downloadopenembedded-core-6f65dd3164a6f523de82cb30e67ec3d180e45c2e.tar.gz
squashfs-tools: clean up compile/install tasks
The makefile can do the right thing now. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
index 0e1be6bc1f..4fd33f8048 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
@@ -28,13 +28,11 @@ PACKAGECONFIG[zstd] = "ZSTD_SUPPORT=1,ZSTD_SUPPORT=0,zstd"
PACKAGECONFIG[reproducible] = "REPRODUCIBLE_DEFAULT=1,REPRODUCIBLE_DEFAULT=0,"
do_compile() {
- oe_runmake mksquashfs unsquashfs
+ oe_runmake all
}
-do_install () {
- install -d ${D}${sbindir}
- install -m 0755 mksquashfs ${D}${sbindir}/
- install -m 0755 unsquashfs ${D}${sbindir}/
+do_install() {
+ oe_runmake install INSTALL_DIR=${D}${sbindir}
}
ARM_INSTRUCTION_SET_armv4 = "arm"