summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/squashfs-tools
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-22 11:29:54 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-27 17:06:27 +0100
commitc9aed6a84c0a33fee8a52603b22cc2b78928eb5f (patch)
tree6a017b509fe20ef38f1d8c8dd3d547948f5392a0 /meta/recipes-devtools/squashfs-tools
parent40187613038aa9c1ca16eaa46d0669f69f80a398 (diff)
downloadopenembedded-core-c9aed6a84c0a33fee8a52603b22cc2b78928eb5f.tar.gz
squashfs-tools: Mark as incompatible with musl
Silently ignoring FNM_EXTMATCH makes fnmatch() behave different from what callers expect. Mark as incompatible with musl instead of risking broken runtime behaviour. The practical consequences should be small since what is used in OE is mainly squashfs-tools-native. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools')
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools/fix-compat.patch46
-rw-r--r--meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb3
2 files changed, 3 insertions, 46 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools/fix-compat.patch b/meta/recipes-devtools/squashfs-tools/squashfs-tools/fix-compat.patch
index 0ce7b4e8ce..87c1e8cac0 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools/fix-compat.patch
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools/fix-compat.patch
@@ -1,39 +1,8 @@
-Define FNM_EXTMATCH if not defined its glibc specific define
include missing sys/stat.h for stat* function declarations
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Index: squashfs-tools/action.c
-===================================================================
---- squashfs-tools.orig/action.c
-+++ squashfs-tools/action.c
-@@ -44,6 +44,10 @@
- #include "action.h"
- #include "error.h"
-
-+#if !defined(FNM_EXTMATCH)
-+#define FNM_EXTMATCH 0
-+#endif
-+
- /*
- * code to parse actions
- */
-Index: squashfs-tools/mksquashfs.c
-===================================================================
---- squashfs-tools.orig/mksquashfs.c
-+++ squashfs-tools/mksquashfs.c
-@@ -1261,6 +1261,10 @@ void write_dir(squashfs_inode *inode, st
- dir_size + 3, directory_block, directory_offset, NULL, NULL,
- dir, 0);
-
-+#if !defined(FNM_EXTMATCH)
-+#define FNM_EXTMATCH 0
-+#endif
-+
- #ifdef SQUASHFS_TRACE
- {
- unsigned char *dirp;
Index: squashfs-tools/pseudo.c
===================================================================
--- squashfs-tools.orig/pseudo.c
@@ -46,18 +15,3 @@ Index: squashfs-tools/pseudo.c
#include <ctype.h>
#include "pseudo.h"
-Index: squashfs-tools/unsquashfs.c
-===================================================================
---- squashfs-tools.orig/unsquashfs.c
-+++ squashfs-tools/unsquashfs.c
-@@ -42,6 +42,10 @@
- #include <sys/sysmacros.h>
- #endif
-
-+#ifndef FNM_EXTMATCH
-+#define FNM_EXTMATCH 0
-+#endif
-+
- struct cache *fragment_cache, *data_cache;
- struct queue *to_reader, *to_inflate, *to_writer, *from_writer;
- pthread_t *thread, *inflator_thread;
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
index 5a8b5f77bd..dc1568a77c 100644
--- a/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
+++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_git.bb
@@ -19,6 +19,9 @@ SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e
S = "${WORKDIR}/git/squashfs-tools"
+# needs FNM_EXTMATCH
+COMPATIBLE_HOST_libc-musl = 'null'
+
EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr"