summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-08-18 13:19:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 09:25:07 +0100
commitd8e65c07ee8a4c6e29922ec37af82ed31ff814cc (patch)
tree55a167534c1b8101eb0d0270e3216f0e62269afd /meta/recipes-devtools/strace
parent67462817222dfa674cf4be7dcd7d4edc5e8631d6 (diff)
downloadopenembedded-core-d8e65c07ee8a4c6e29922ec37af82ed31ff814cc.tar.gz
strace: fix ptest execution failure
ptest needs runtest-TESTS target. serial-tests is required to generate this target. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace')
-rw-r--r--meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch b/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
index f5556b23e3..3a0eb39375 100644
--- a/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
+++ b/meta/recipes-devtools/strace/strace-4.8/Makefile-ptest.patch
@@ -1,11 +1,13 @@
strace: Add ptest
+Upstream-Status: Inappropriate
+
Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
-Upstream-Status: Pending
+Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
--- old/tests/Makefile.am 2013-07-23 13:44:24.660481381 +0200
+++ new/tests/Makefile.am 2013-07-23 16:22:42.937654391 +0200
-@@ -9,3 +9,20 @@
+@@ -9,3 +9,21 @@
EXTRA_DIST = init.sh $(TESTS)
CLEANFILES = check.log
@@ -18,6 +20,7 @@ Upstream-Status: Pending
+ install -d $(DESTDIR)/$(TESTDIR)
+ cp $(BUILDDIR)/$(TESTDIR)/Makefile $(DESTDIR)/$(TESTDIR)
+ sed -i -e 's/^Makefile:/_Makefile:/' $(DESTDIR)/$(TESTDIR)/Makefile
++ sed -i -e 's/bash/sh/' $(DESTDIR)/$(TESTDIR)/Makefile
+ for file in $(check_PROGRAMS); do \
+ install $(BUILDDIR)/$(TESTDIR)/$$file $(DESTDIR)/$(TESTDIR); \
+ done
@@ -26,3 +29,13 @@ Upstream-Status: Pending
+ sed -i -e 's/$${srcdir=.}/./g' $(DESTDIR)/$(TESTDIR)/$$file; \
+ done
+ sed -i -e 's/$$srcdir/./g' $(DESTDIR)/$(TESTDIR)/net
+--- a/configure.ac
++++ b/configure.ac
+@@ -6,7 +6,7 @@ AC_INIT([strace],
+ AC_CONFIG_SRCDIR([strace.c])
+ AC_CONFIG_AUX_DIR([.])
+ AC_CONFIG_HEADERS([config.h])
+-AM_INIT_AUTOMAKE([foreign dist-xz no-dist-gzip silent-rules])
++AM_INIT_AUTOMAKE([foreign dist-xz no-dist-gzip silent-rules serial-tests])
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST