summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind-3.7.0
diff options
context:
space:
mode:
authorRadu Moisan <radu.moisan@intel.com>2013-01-22 17:29:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-28 12:25:35 +0000
commitdf0d23c2bedafd534c5909a65afaf3373d7bc33e (patch)
tree75a1dde1b6eb58b026a039445b1765ae220d7d41 /meta/recipes-devtools/valgrind/valgrind-3.7.0
parent7255c43b6e545a4c15c3cd57f6c240668a77786a (diff)
downloadopenembedded-core-df0d23c2bedafd534c5909a65afaf3373d7bc33e.tar.gz
valgrind: update to 3.8.1
Changed license copyright notice 2011->2012 remove unnecessary patches built for x86, 86-64, ppc Signed-off-by: Radu Moisan <radu.moisan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind-3.7.0')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/Added-support-for-PPC-instructions-mfatbu-mfatbl.patch96
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-fix.patch40
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-with-newer-glibc.patch40
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch45
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_issue_caused_by_ccache.patch32
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_unsupporting_kernel_3.patch26
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/fixed-perl-path.patch53
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.7.0/valgrind-3.7.0-fix-error-of-reading-debug-info.patch33
8 files changed, 0 insertions, 365 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/Added-support-for-PPC-instructions-mfatbu-mfatbl.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/Added-support-for-PPC-instructions-mfatbu-mfatbl.patch
deleted file mode 100644
index 07774f38a9..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/Added-support-for-PPC-instructions-mfatbu-mfatbl.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From 0bf4b0ac18d1ea41b32ad781d214b295ca1998f3 Mon Sep 17 00:00:00 2001
-From: Aneesh Bansal <aneesh.bansal@freescale.com>
-Date: Mon, 21 Nov 2011 17:31:39 +0530
-Subject: [PATCH] Added support for PPC instructions mfatbu, mfatbl.
-
-Upstream-Status: Pending
-
-Signed-off-by: Aneesh Bansal <aneesh.bansal@freescale.com>
----
-Currently Valgrind 3.7.0 does not have support for PPC instructions mfatbu and mfatbl. When we run a USDPAA application with VALGRIND, the following error is given by valgrind :
-dis_proc_ctl(ppc)(mfspr,SPR)(0x20F)
-disInstr(ppc): unhandled instruction: 0x7C0F82A6
-
-
- VEX/priv/guest_ppc_defs.h | 2 ++
- VEX/priv/guest_ppc_helpers.c | 18 ++++++++++++++++++
- VEX/priv/guest_ppc_toIR.c | 22 ++++++++++++++++++++++
- 3 files changed, 42 insertions(+), 0 deletions(-)
-
-diff --git a/VEX/priv/guest_ppc_defs.h b/VEX/priv/guest_ppc_defs.h
-index dd3c62e..11a34aa 100644
---- a/VEX/priv/guest_ppc_defs.h
-+++ b/VEX/priv/guest_ppc_defs.h
-@@ -146,6 +146,8 @@ extern UInt ppc32g_dirtyhelper_MFSPR_268_269 ( UInt );
-
- extern UInt ppc32g_dirtyhelper_MFSPR_287 ( void );
-
-+extern UInt ppc32g_dirtyhelper_MFSPR_526_527 ( UInt );
-+
- extern void ppc32g_dirtyhelper_LVS ( VexGuestPPC32State* gst,
- UInt vD_idx, UInt sh,
- UInt shift_right );
-diff --git a/VEX/priv/guest_ppc_helpers.c b/VEX/priv/guest_ppc_helpers.c
-index 11aa428..b49ea3f 100644
---- a/VEX/priv/guest_ppc_helpers.c
-+++ b/VEX/priv/guest_ppc_helpers.c
-@@ -119,6 +119,24 @@ UInt ppc32g_dirtyhelper_MFSPR_287 ( void )
- # endif
- }
-
-+/* CALLED FROM GENERATED CODE */
-+/* DIRTY HELPER (non-referentially transparent) */
-+UInt ppc32g_dirtyhelper_MFSPR_526_527 ( UInt r527 )
-+{
-+# if defined(__powerpc__) || defined(_AIX)
-+ UInt spr;
-+ if (r527) {
-+ __asm__ __volatile__("mfspr %0,527" : "=b"(spr));
-+ } else {
-+ __asm__ __volatile__("mfspr %0,526" : "=b"(spr));
-+ }
-+ return spr;
-+# else
-+ return 0;
-+# endif
-+}
-+
-+
-
- /* CALLED FROM GENERATED CODE */
- /* DIRTY HELPER (reads guest state, writes guest mem) */
-diff --git a/VEX/priv/guest_ppc_toIR.c b/VEX/priv/guest_ppc_toIR.c
-index f8d220d..37c8974 100644
---- a/VEX/priv/guest_ppc_toIR.c
-+++ b/VEX/priv/guest_ppc_toIR.c
-@@ -5657,6 +5657,28 @@ static Bool dis_proc_ctl ( VexAbiInfo* vbi, UInt theInstr )
- break;
- }
-
-+
-+ case 526 /* 0x20E */:
-+ case 527 /* 0x20F */: {
-+ UInt arg = SPR==526 ? 0 : 1;
-+ IRTemp val = newTemp(Ity_I32);
-+ IRExpr** args = mkIRExprVec_1( mkU32(arg) );
-+ IRDirty* d = unsafeIRDirty_1_N(
-+ val,
-+ 0/*regparms*/,
-+ "ppc32g_dirtyhelper_MFSPR_526_527",
-+ fnptr_to_fnentry
-+ (vbi, &ppc32g_dirtyhelper_MFSPR_526_527),
-+ args
-+ );
-+ /* execute the dirty call, dumping the result in val. */
-+ stmt( IRStmt_Dirty(d) );
-+ putIReg( rD_addr,
-+ mkWidenFrom32(ty, mkexpr(val), False/*unsigned*/) );
-+ DIP("mfspr r%u,%u", rD_addr, (UInt)SPR);
-+ break;
-+ }
-+
- default:
- vex_printf("dis_proc_ctl(ppc)(mfspr,SPR)(0x%x)\n", SPR);
- return False;
---
-1.7.0.4
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-fix.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-fix.patch
deleted file mode 100644
index 1f4bd7ef40..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-fix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-To recognize gcc version from poky in configure.in
-Added GLIBC 2.15 stanza to supported GLIBCs
-
-Upstream-Status: Inappropriate [configuration]
-
-Signed-off-by: Shane Wang <shane.wang@intel.com>
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-
-Index: valgrind-3.7.0/configure.in
-===================================================================
---- valgrind-3.7.0.orig/configure.in
-+++ valgrind-3.7.0/configure.in
-@@ -104,11 +104,13 @@ AC_MSG_CHECKING([for a supported version
- #
- # i686-apple-darwin10-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5666) (dot 3)
- # i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)
-+# ARCH-VENDOR-OS-gcc (GCC) VERSION Copyright
- #
- [gcc_version=`${CC} --version \
- | head -n 1 \
- | $SED 's/i686-apple-darwin10//' \
- | $SED 's/i686-apple-darwin11//' \
-+ | $SED 's/.*GCC[^0-9]*//' \
- | $SED 's/^[^0-9]*\([0-9.]*\).*$/\1/'`]
-
- is_clang="notclang"
-@@ -779,6 +781,13 @@ case "${GLIBC_VERSION}" in
- DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
- DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
- ;;
-+ 2.15)
-+ AC_MSG_RESULT(2.15 family)
-+ AC_DEFINE([GLIBC_2_15], 1, [Define to 1 if you're using glibc 2.15.x])
-+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
-+ ;;
- darwin)
- AC_MSG_RESULT(Darwin)
- AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-with-newer-glibc.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-with-newer-glibc.patch
deleted file mode 100644
index b369de8901..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/configure-with-newer-glibc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Add case for glibc 2.16 and correct error message to denote support until 2.16
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-
-Upstream-Status: Pending
-Index: valgrind-3.7.0/configure.in
-===================================================================
---- valgrind-3.7.0.orig/configure.in
-+++ valgrind-3.7.0/configure.in
-@@ -788,6 +788,20 @@ case "${GLIBC_VERSION}" in
- DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
- DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
- ;;
-+ 2.16)
-+ AC_MSG_RESULT(2.16 family)
-+ AC_DEFINE([GLIBC_2_16], 1, [Define to 1 if you're using glibc 2.16.x])
-+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
-+ ;;
-+ 2.17)
-+ AC_MSG_RESULT(2.17 family)
-+ AC_DEFINE([GLIBC_2_17], 1, [Define to 1 if you're using glibc 2.17.x])
-+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
-+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
-+ ;;
- darwin)
- AC_MSG_RESULT(Darwin)
- AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
-@@ -801,7 +815,7 @@ case "${GLIBC_VERSION}" in
-
- *)
- AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
-- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.14])
-+ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.17])
- AC_MSG_ERROR([or Darwin libc])
- ;;
- esac
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch
deleted file mode 100644
index 866facfeb2..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_for_automake_1.11.2.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Upstream-Status: Pending
-
-automake version 1.11.2 has made use of dir variables more strict.
-the use of pkglibdir with DATA var results in automake errors.
-
-This commits uses pkgdatadir var instead of pkglibdir to avoid
-the strict check errors.
-
-RP 2012/1/4
-
-Index: valgrind-3.7.0/Makefile.am
-===================================================================
---- valgrind-3.7.0.orig/Makefile.am 2012-01-04 15:55:07.034044860 +0000
-+++ valgrind-3.7.0/Makefile.am 2012-01-04 15:55:55.034035120 +0000
-@@ -61,7 +61,7 @@
- # default.supp, as it is built from the base .supp files at compile-time.
- dist_noinst_DATA = $(SUPP_FILES)
-
--pkglib_DATA = default.supp
-+pkgdata_DATA = default.supp
-
- pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = valgrind.pc
-Index: valgrind-3.7.0/coregrind/Makefile.am
-===================================================================
---- valgrind-3.7.0.orig/coregrind/Makefile.am 2012-01-04 15:55:02.090043851 +0000
-+++ valgrind-3.7.0/coregrind/Makefile.am 2012-01-04 15:55:30.270044097 +0000
-@@ -495,7 +495,7 @@
- m_gdbserver/powerpc-altivec64l.xml
-
- # so as to make sure these get copied into the install tree
--pkglib_DATA = $(GDBSERVER_XML_FILES)
-+pkgdata_DATA = $(GDBSERVER_XML_FILES)
-
- # so as to make sure these get copied into the tarball
- EXTRA_DIST += $(GDBSERVER_XML_FILES)
-@@ -506,7 +506,7 @@
-
- all-local: inplace-noinst_PROGRAMS inplace-noinst_DSYMS
- mkdir -p $(inplacedir); \
-- for f in $(pkglib_DATA); do \
-+ for f in $(pkgdata_DATA); do \
- rm -f $(inplacedir)/$$f; \
- ln -f -s ../$(subdir)/$$f $(inplacedir); \
- done
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_issue_caused_by_ccache.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_issue_caused_by_ccache.patch
deleted file mode 100644
index 4658567b21..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_issue_caused_by_ccache.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-The script does not expect use of ccache, hence fix it to recognise it.
-
-2010/08/17
-Nitin A Kamble <nitin.a.kamble@intel.com>
-
-Upstream-Status: Inappropriate [configuration]
-
-Index: valgrind-3.5.0/coregrind/link_tool_exe_linux.in
-===================================================================
---- valgrind-3.5.0.orig/coregrind/link_tool_exe_linux.in
-+++ valgrind-3.5.0/coregrind/link_tool_exe_linux.in
-@@ -62,6 +62,11 @@ die "Bogus alt-load address"
-
- # The cc invokation to do the final link
- my $cc = $ARGV[1];
-+my $next = 2;
-+if ("$cc" eq "ccache") {
-+ $cc = "$cc $ARGV[2]";
-+ $next = 3;
-+}
-
- # and the 'restargs' are argv[2 ..]
-
-@@ -71,7 +76,7 @@ my $cc = $ARGV[1];
- my $cmd="$cc -static -Wl,-Ttext=$ala";
-
- # Add the rest of the parameters
--foreach my $n (2 .. $#ARGV) {
-+foreach my $n ($next .. $#ARGV) {
- $cmd = "$cmd $ARGV[$n]";
- }
-
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_unsupporting_kernel_3.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_unsupporting_kernel_3.patch
deleted file mode 100644
index 346ffebb3d..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fix_unsupporting_kernel_3.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-valgrind: Add 3.x statements to "case" for supporting the kernel 3.x
-
-Signed-off-by: Lin Tong <tong.lin@intel.com>
-
-Upstream-Status: Pending
-
-diff --git a/configure.in b/configure.in
-index 3878619..1cb7dc7 100644
---- a/configure.in
-+++ b/configure.in
-@@ -229,10 +229,14 @@ case "${host_os}" in
- AC_MSG_RESULT([2.4 family (${kernel})])
- AC_DEFINE([KERNEL_2_4], 1, [Define to 1 if you're using Linux 2.4.x])
- ;;
-+ 3.*)
-+ AC_MSG_RESULT([3 family (${kernel})])
-+ AC_DEFINE([KERNEL_3], 1, [Define to 1 if you're using Linux 3.x])
-+ ;;
-
- *)
- AC_MSG_RESULT([unsupported (${kernel})])
-- AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
-+ AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6, 3.x])
- ;;
- esac
-
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fixed-perl-path.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/fixed-perl-path.patch
deleted file mode 100644
index b054d05f7f..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/fixed-perl-path.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-this is a temporary patch to workaround cross compilation.
-otherwise @PERL@ will be replaced to perl-native binary,
-this creates unusable scripts and fails FILERDEPENDS mechanism
-(esp. rpm)
-
-a better fix would need:
- 1. configure.ac should differentiate PERL and HOSTPERL
- 2. optionally remove ${STAGING_DIR} in #! line before do_install
-
-8/31/2010 - created by Qing He <qing.he@intel.com>
-
-Upstream-Status: Inappropriate [configuration]
-
-diff --git a/cachegrind/cg_annotate.in b/cachegrind/cg_annotate.in
-index 9dc9565..cc4ef05 100644
---- a/cachegrind/cg_annotate.in
-+++ b/cachegrind/cg_annotate.in
-@@ -1,4 +1,4 @@
--#! @PERL@
-+#! /usr/bin/perl
-
- ##--------------------------------------------------------------------##
- ##--- Cachegrind's annotator. cg_annotate.in ---##
-diff --git a/cachegrind/cg_diff.in b/cachegrind/cg_diff.in
-index 951066e..84c2dde 100644
---- a/cachegrind/cg_diff.in
-+++ b/cachegrind/cg_diff.in
-@@ -1,4 +1,4 @@
--#! @PERL@
-+#! /usr/bin/perl
-
- ##--------------------------------------------------------------------##
- ##--- Cachegrind's differencer. cg_diff.in ---##
-diff --git a/massif/ms_print.in b/massif/ms_print.in
-index e6ffdbf..fb45906 100755
---- a/massif/ms_print.in
-+++ b/massif/ms_print.in
-@@ -1,4 +1,4 @@
--#! @PERL@
-+#! /usr/bin/perl
-
- ##--------------------------------------------------------------------##
- ##--- Massif's results printer ms_print.in ---##
-diff --git a/perf/vg_perf.in b/perf/vg_perf.in
-index 2188a31..83ad024 100644
---- a/perf/vg_perf.in
-+++ b/perf/vg_perf.in
-@@ -1,4 +1,4 @@
--#! @PERL@
-+#! /usr/bin/perl
- ##--------------------------------------------------------------------##
- ##--- Valgrind performance testing script vg_perf ---##
- ##--------------------------------------------------------------------##
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.7.0/valgrind-3.7.0-fix-error-of-reading-debug-info.patch b/meta/recipes-devtools/valgrind/valgrind-3.7.0/valgrind-3.7.0-fix-error-of-reading-debug-info.patch
deleted file mode 100644
index b1626f0b0f..0000000000
--- a/meta/recipes-devtools/valgrind/valgrind-3.7.0/valgrind-3.7.0-fix-error-of-reading-debug-info.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Upstream-Status: Pending
-
-fix debug info reading error when do memcheck on ppc targets
- following is the error message:
- --2263-- WARNING: Serious error when reading debug info
- --2263-- When reading debug info from /lib/ld-2.13.so:
- --2263-- Can't make sense of .got section mapping
- --2263-- WARNING: Serious error when reading debug info
- --2263-- When reading debug info from /home/root/lzh:
- --2263-- Can't make sense of .data section mapping
- --2263-- WARNING: Serious error when reading debug info
- --2263-- When reading debug info from /usr/lib/valgrind/vgpreload_core-ppc32-linux.so:
- --2263-- Can't make sense of .data section mapping
- --2263-- WARNING: Serious error when reading debug info
- --2263-- When reading debug info from /usr/lib/valgrind/vgpreload_memcheck-ppc32-linux.so:
- --2263-- Can't make sense of .data section mapping
- --2263-- WARNING: Serious error when reading debug info
- --2263-- When reading debug info from /lib/libc-2.13.so:
- --2263-- Can't make sense of .data section mapping
-
-Signed-off-by: Zhenhua Luo <b19537@freescale.com>
-
---- a/coregrind/m_debuginfo/readelf.c 2012-09-11 21:45:36.696462313 -0500
-+++ b/coregrind/m_debuginfo/readelf.c 2012-09-11 21:45:49.913463615 -0500
-@@ -1539,7 +1539,7 @@
- && phdr->p_offset < di->fsm.rw_map_foff + di->fsm.rw_map_size
- && phdr->p_offset + phdr->p_filesz
- <= di->fsm.rw_map_foff + di->fsm.rw_map_size
-- && (phdr->p_flags & (PF_R | PF_W | PF_X)) == (PF_R | PF_W)) {
-+ && (phdr->p_flags & (PF_R | PF_W | PF_X)) >= (PF_R | PF_W)) {
- if (n_rw == N_RX_RW_AREAS) {
- ML_(symerr)(di, True,
- "N_RX_RW_AREAS is too low; "