summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-24 13:44:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-26 09:33:28 +0000
commit0e359ba5134d8071c590936e0348e5bf97919845 (patch)
treea1915f030f0552f1c2fce7d8d67ab180ae931f12 /meta/recipes-devtools
parentaa662aae352c65cb5d13172bf98ed4ae3cb46c26 (diff)
downloadopenembedded-core-0e359ba5134d8071c590936e0348e5bf97919845.tar.gz
perl: Add missing RDEPENDS
This allows quilt-ptest to work in an otherwise bare image. Without this there are broken modules. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/files/perl-rdepends.txt4
-rw-r--r--meta/recipes-devtools/perl/perl_5.34.1.bb4
2 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/files/perl-rdepends.txt b/meta/recipes-devtools/perl/files/perl-rdepends.txt
index 3415f32ab1..74c24c3bb5 100644
--- a/meta/recipes-devtools/perl/files/perl-rdepends.txt
+++ b/meta/recipes-devtools/perl/files/perl-rdepends.txt
@@ -1,7 +1,11 @@
# Some additional dependencies that the above doesn't manage to figure out
RDEPENDS:perl-module-file-spec += "perl-module-file-spec-unix"
+RDEPENDS:perl-module-scalar-util += "perl-module-list-util"
+RDEPENDS:perl-module-file-temp += "perl-module-scalar-util"
+RDEPENDS:perl-module-file-temp += "perl-module-file-spec"
RDEPENDS:perl-module-io-file += "perl-module-symbol"
+RDEPENDS:perl-module-io-file += "perl-module-carp"
RDEPENDS:perl-module-math-bigint += "perl-module-math-bigint-calc"
RDEPENDS:perl-module-test-builder += "perl-module-list-util"
RDEPENDS:perl-module-test-builder += "perl-module-scalar-util"
diff --git a/meta/recipes-devtools/perl/perl_5.34.1.bb b/meta/recipes-devtools/perl/perl_5.34.1.bb
index 608a42189b..0e9d0c032e 100644
--- a/meta/recipes-devtools/perl/perl_5.34.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.1.bb
@@ -355,7 +355,11 @@ do_create_rdepends_inc() {
# Some additional dependencies that the above doesn't manage to figure out
RDEPENDS:${PN}-module-file-spec += "${PN}-module-file-spec-unix"
+RDEPENDS:${PN}-module-scalar-util += "${PN}-module-list-util"
+RDEPENDS:${PN}-module-file-temp += "${PN}-module-scalar-util"
+RDEPENDS:${PN}-module-file-temp += "${PN}-module-file-spec"
RDEPENDS:${PN}-module-io-file += "${PN}-module-symbol"
+RDEPENDS:${PN}-module-io-file += "${PN}-module-carp"
RDEPENDS:${PN}-module-math-bigint += "${PN}-module-math-bigint-calc"
RDEPENDS:${PN}-module-test-builder += "${PN}-module-list-util"
RDEPENDS:${PN}-module-test-builder += "${PN}-module-scalar-util"