summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-18 22:18:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-20 08:53:00 +0100
commit1f2276c6d0312854caacebe1c83dee57474f1bb2 (patch)
treefa8c0a3d005706288d3b65af81c9ab3bb3471dbf /meta/recipes-devtools
parent9c7768d26a006445ed703e961184be3b8add68c6 (diff)
downloadopenembedded-core-1f2276c6d0312854caacebe1c83dee57474f1bb2.tar.gz
python3-hypothesis: upgrade 6.14.5 -> 6.14.8
6.14.8 - 2021-08-16 This patch ensures that registering a strategy for a subclass of a parametrised generic type such as class Lines(Sequence[str]): will not “leak” into unrelated strategies such as st.from_type(Sequence[int]) (issue #2951). Unfortunately this fix requires PEP 560, meaning Python 3.7 or later. 6.14.7 - 2021-08-14 This patch fixes issue #3050, where attrs classes could cause an internal error in the ghostwriter. 6.14.6 - 2021-08-07 This patch improves the error message for issue #3016, where PEP 585 builtin generics with self-referential forward-reference strings cannot be resolved to a strategy by from_type(). References: https://github.com/HypothesisWorks/hypothesis/issues/2951 https://www.python.org/dev/peps/pep-0560 https://github.com/HypothesisWorks/hypothesis/issues/3050 https://www.python.org/dev/peps/pep-0585 Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.14.8.bb (renamed from meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb b/meta/recipes-devtools/python/python3-hypothesis_6.14.8.bb
index 0460a43198..bc29b94a54 100644
--- a/meta/recipes-devtools/python/python3-hypothesis_6.14.5.bb
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.14.8.bb
@@ -7,7 +7,7 @@ PYPI_PACKAGE = "hypothesis"
inherit pypi setuptools3
-SRC_URI[sha256sum] = "0563b9711fd9bf478cb591580a575c369d2c396f283efa85d0f9a75b26db65b5"
+SRC_URI[sha256sum] = "cb80e06ca44992b08d2889734b740e67c8b41337315bbd6dba2ef43ca816cfe3"
RDEPENDS:${PN} += " \
python3-attrs \