summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-07-12 15:56:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-13 14:24:57 +0100
commit9720cce06206895e2e85b171d58a289172bb9092 (patch)
tree1219f34de8c25c13eb5f0a6944353b6fb16be0a6 /meta/recipes-devtools
parent3685b51982ac4f611d3e235c8818474563548bd9 (diff)
downloadopenembedded-core-9720cce06206895e2e85b171d58a289172bb9092.tar.gz
python3-setuptools: upgrade 57.0.0 -> 57.1.0
reproducibility.patch deleted since it's been merged upstream. v57.1.0 ------- Changes ^^^^^^^ * #2692: Globs are now sorted in 'license_files' restoring reproducibility by eliminating variance from disk order. * #2714: Update to distutils at pypa/distutils@e2627b7. * #2715: Removed reliance on deprecated ssl.match_hostname by removing the ssl support. Now any index operations rely on the native SSL implementation. Documentation changes ^^^^^^^^^^^^^^^^^^^^^ * #2604: Revamped the backward/cross tool compatibility section to remove some confusion. Add some examples and the version since when ``entry_points`` are supported in declarative configuration. Tried to make the reading flow a bit leaner, gather some informations that were a bit dispersed. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools/reproducibility.patch40
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_57.1.0.bb (renamed from meta/recipes-devtools/python/python3-setuptools_57.0.0.bb)5
2 files changed, 2 insertions, 43 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools/reproducibility.patch b/meta/recipes-devtools/python/python3-setuptools/reproducibility.patch
deleted file mode 100644
index 149d8ad5ce..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools/reproducibility.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-The License-File lines in PKG-INFO change ordering depending on the order on disk,
-for example for python-packaging, one build shows:
-
-License-File: LICENSE
-License-File: LICENSE.APACHE
-License-File: LICENSE.BSD
-
-and the other shows:
-
-License-File: LICENSE
-License-File: LICENSE.BSD
-License-File: LICENSE.APACHE
-
-This is because glob uses os.listdir() which is unsorted. Sort the result to avoid this.
-
-Upstream-Status: Submitted [https://github.com/pypa/setuptools/issues/2691]
-Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-
-Index: setuptools-57.0.0/setuptools/dist.py
-===================================================================
---- setuptools-57.0.0.orig/setuptools/dist.py
-+++ setuptools-57.0.0/setuptools/dist.py
-@@ -15,7 +15,7 @@ import distutils.command
- from distutils.util import strtobool
- from distutils.debug import DEBUG
- from distutils.fancy_getopt import translate_longopt
--from glob import iglob
-+from glob import glob
- import itertools
- import textwrap
- from typing import List, Optional, TYPE_CHECKING
-@@ -603,7 +603,7 @@ class Distribution(_Distribution):
- return (
- path
- for pattern in patterns
-- for path in iglob(pattern)
-+ for path in sorted(glob(pattern))
- if not path.endswith('~')
- and os.path.isfile(path)
- )
diff --git a/meta/recipes-devtools/python/python3-setuptools_57.0.0.bb b/meta/recipes-devtools/python/python3-setuptools_57.1.0.bb
index a15b51e31c..c066d8209f 100644
--- a/meta/recipes-devtools/python/python3-setuptools_57.0.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_57.1.0.bb
@@ -8,10 +8,9 @@ inherit pypi setuptools3
SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
-SRC_URI += "file://0001-change-shebang-to-python3.patch \
- file://reproducibility.patch"
+SRC_URI += "file://0001-change-shebang-to-python3.patch"
-SRC_URI[sha256sum] = "401cbf33a7bf817d08014d51560fc003b895c4cdc1a5b521ad2969e928a07535"
+SRC_URI[sha256sum] = "cfca9c97e7eebbc8abe18d5e5e962a08dcad55bb63afddd82d681de4d22a597b"
DEPENDS += "${PYTHON_PN}"