summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2013-12-19 11:34:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-20 12:25:22 +0000
commit59c847b8cda4d70077c89f5761e000d089f8eb4b (patch)
tree3ae68f6286f188328c3f9918a167ed93f16122b0 /meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch
parent8629844640a5a4c6a9d9375e7b637bcbf3451c4c (diff)
downloadopenembedded-core-59c847b8cda4d70077c89f5761e000d089f8eb4b.tar.gz
libtirpc: upgrade to 0.2.4
obsolete_automake_macros.patch removed, no longer needed. Disabled GSS APIs, as those APIs are not present in our distro. Patches directory is now generic, as patches are not created for a specific version. (From OE-Core rev: 3d42e107379d2e79b14a2dbcd35820c63adbfdb0) Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch b/meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch
new file mode 100644
index 0000000000..d003348af9
--- /dev/null
+++ b/meta/recipes-extended/libtirpc/libtirpc/remove-des-uclibc.patch
@@ -0,0 +1,38 @@
+uclibc does not provide des functionality unlike eglibc so lets disable ssl support
+
+Upstream-Status: Inappropriate [uclibc specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libtirpc-0.2.3/src/rpc_soc.c
+===================================================================
+--- libtirpc-0.2.3.orig/src/rpc_soc.c 2013-03-10 16:00:51.355282153 -0700
++++ libtirpc-0.2.3/src/rpc_soc.c 2013-03-10 16:00:51.703282148 -0700
+@@ -520,6 +520,7 @@
+ (resultproc_t) rpc_wrap_bcast, "udp");
+ }
+
++#if 0
+ /*
+ * Create the client des authentication object. Obsoleted by
+ * authdes_seccreate().
+@@ -551,6 +552,7 @@
+ dummy = authdes_seccreate(servername, window, NULL, ckey);
+ return (dummy);
+ }
++#endif
+
+ /*
+ * Create a client handle for a unix connection. Obsoleted by clnt_vc_create()
+Index: libtirpc-0.2.3/src/Makefile.am
+===================================================================
+--- libtirpc-0.2.3.orig/src/Makefile.am 2013-03-10 16:00:51.355282153 -0700
++++ libtirpc-0.2.3/src/Makefile.am 2013-03-10 16:00:51.703282148 -0700
+@@ -50,7 +50,7 @@
+ rpc_callmsg.c rpc_generic.c rpc_soc.c rpcb_clnt.c rpcb_prot.c \
+ rpcb_st_xdr.c svc.c svc_auth.c svc_dg.c svc_auth_unix.c svc_auth_none.c \
+ svc_generic.c svc_raw.c svc_run.c svc_simple.c svc_vc.c getpeereid.c \
+- auth_time.c auth_des.c authdes_prot.c
++ auth_time.c
+
+ ## XDR
+ libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c