summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-01-16 08:32:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-18 12:49:23 +0000
commit6b87ad5b08004554f08d2f68027908956f3795e1 (patch)
tree725f00782d11f9b5cd3a186b2f9b60f1f361f692 /meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
parentc08f76ba0654e43074b6b964f728765918dbfb09 (diff)
downloadopenembedded-core-6b87ad5b08004554f08d2f68027908956f3795e1.tar.gz
json-glib: update to 1.4.2
Drop 0001-Do-not-disable-gobject-introspection-when-cross-comp.patch since it has been fixed upstream. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/json-glib/json-glib_1.4.2.bb')
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.4.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb b/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
new file mode 100644
index 0000000000..fad0a2df36
--- /dev/null
+++ b/meta/recipes-gnome/json-glib/json-glib_1.4.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
+DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
+ data structures, using a DOM-like API. JSON-GLib also offers GObject \
+integration, providing the ability to serialize and deserialize GObject \
+instances to and from JSON data types."
+HOMEPAGE = "http://live.gnome.org/JsonGlib"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
+
+DEPENDS = "glib-2.0"
+
+SRC_URI[archive.md5sum] = "35107e23a7bbbc70f31c34f7b9adf1c3"
+SRC_URI[archive.sha256sum] = "2d7709a44749c7318599a6829322e081915bdc73f5be5045882ed120bb686dc8"
+
+GNOMEBASEBUILDCLASS = "meson"
+inherit gnomebase lib_package gobject-introspection gtk-doc manpages gettext
+
+GTKDOC_ENABLE_FLAG = "-Denable-gtk-doc=true"
+GTKDOC_DISABLE_FLAG = "-Denable-gtk-doc=false"
+
+GI_ENABLE_FLAG = "-Ddisable_introspection=false"
+GI_DISABLE_FLAG = "-Ddisable_introspection=true"
+
+EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \
+ '${GTKDOC_DISABLE_FLAG}', d)} "
+EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
+ '${GI_DISABLE_FLAG}', d)} "
+
+PACKAGECONFIG[manpages] = "-Denable-man=true, -Denable-man=false, libxslt-native xmlto-native"
+
+do_install_append() {
+ # FIXME: these need to be provided via ptest
+ rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
+}
+
+BBCLASSEXTEND = "native nativesdk"