summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-05-06 15:17:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-10 09:51:40 +0100
commit03f442250579a392b49b54648840fbeb7c0a0142 (patch)
tree37887c11bd67a13caee99b1430097b40271a95ac /meta/recipes-kernel/lttng/lttng-ust
parentfdbcf8eea9d83a8040157d8a5bb6febae5eb9a14 (diff)
downloadopenembedded-core-03f442250579a392b49b54648840fbeb7c0a0142.tar.gz
lttng-ust_0.12.bb: Fix compilation on uclibc
We provide alternative implementation of sched_getcpu() when compiling for uclibc Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch b/meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch
new file mode 100644
index 0000000000..7102a69184
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch
@@ -0,0 +1,50 @@
+uClibc does not have sched_getcpu() implemented. So we create a wrapper
+to getcpu syscall when compiling for uclibc.
+
+So far execinfo.h does not exist on uclibc but it turns out to be that
+this header is not needed even in eglibc case so it can be removed
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-status: Pending
+
+Index: ust-0.12/libust/tracer.h
+===================================================================
+--- ust-0.12.orig/libust/tracer.h
++++ ust-0.12/libust/tracer.h
+@@ -342,14 +342,22 @@ static __inline__ void ltt_write_trace_h
+ header->start_freq = trace->start_freq;
+ header->freq_scale = trace->freq_scale;
+ }
+-
++#ifdef __UCLIBC__
++#define sched_getcpu(cpu, node, cache) syscall(__NR_getcpu, cpu, node, cache)
++#endif
+ #ifndef UST_VALGRIND
+
+ static __inline__ int ust_get_cpu(void)
+ {
+ int cpu;
+
++#ifdef __UCLIBC__
++ int c, s;
++ s = syscall(__NR_getcpu, &c, NULL, NULL);
++ cpu = (s == -1) ? s : c;
++#else
+ cpu = sched_getcpu();
++#endif
+ if (likely(cpu >= 0))
+ return cpu;
+ /*
+Index: ust-0.12/libustcomm/ustcomm.c
+===================================================================
+--- ust-0.12.orig/libustcomm/ustcomm.c
++++ ust-0.12/libustcomm/ustcomm.c
+@@ -31,7 +31,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <execinfo.h>
+
+ #include "ustcomm.h"
+ #include "usterr.h"