summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorKonrad Scherer <Konrad.Scherer@windriver.com>2013-11-07 13:36:26 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-09 18:01:36 +0000
commit963315939610a89b031346ebf93cd5bddc7773d2 (patch)
tree3cab52f9cba7251ae5a6a31ad3a1650ffbbdea65 /meta/recipes-kernel
parent664ae3dc52fd7fc8c6f64e6cf5e70f97dedd332d (diff)
downloadopenembedded-core-963315939610a89b031346ebf93cd5bddc7773d2.tar.gz
perf: Disable warnings as errors for kernels 3.1+
Turns out the sed command has not been working as intended since kernel 3.1 due to the trailing space. Adding the WERROR=0 environment variable is the correct way to disable warnings as errors. Signed-off-by: Konrad Scherer <Konrad.Scherer@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 903ffa6eaf..6258cbbe09 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -41,6 +41,9 @@ export STAGING_LIBDIR
export BUILD_SYS
export HOST_SYS
+#kernel 3.1+ supports WERROR to disable warnings as errors
+export WERROR = "0"
+
do_populate_lic[depends] += "virtual/kernel:do_populate_sysroot"
# needed for building the tools/perf Perl binding
@@ -115,6 +118,7 @@ do_install() {
}
do_configure_prepend () {
+ #kernels before 3.1 do not support WERROR env variable
sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
}