summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2012-08-17 11:11:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-17 13:10:04 +0100
commitd6aa123fdbfa82c07e33a9b4c7aacad821184790 (patch)
treeae20593492b1ccaee47450bdf32289ed0cb1bbbf /meta/recipes-support/apr
parent62187bdbaf39b116c2ce4d924dd9b670716b744c (diff)
downloadopenembedded-core-d6aa123fdbfa82c07e33a9b4c7aacad821184790.tar.gz
apr-util: fix the rules.mk with path to sysroot instead of the workdir of apr
The copying for rules.mk was happened in do_configure_prepend, but it will be replaced by the one generated by configure, in which APR_MKEXPORT points to the workdir of apr and cause compile filure when the workdir of apr is removed. So change the copying in _prepend to _append. [YOCTO #2947] Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/apr')
-rw-r--r--meta/recipes-support/apr/apr-util_1.4.1.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.4.1.bb b/meta/recipes-support/apr/apr-util_1.4.1.bb
index deb608f8de..0516bc4acc 100644
--- a/meta/recipes-support/apr/apr-util_1.4.1.bb
+++ b/meta/recipes-support/apr/apr-util_1.4.1.bb
@@ -32,8 +32,10 @@ inherit autotools lib_package binconfig
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
-do_configure_prepend() {
- cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+do_configure_append() {
+ if [ "${PN}" == "${BPN}" ]; then
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ fi
}
do_configure_prepend_virtclass-native() {
cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${S}/build/rules.mk