summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-20 15:08:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-23 22:31:26 +0000
commit3bbebc39235f50af4d66e3284b67c1491d2c93f2 (patch)
tree442c1ca71379b1bab186b54dbf6efa3d61df8cf3 /meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
parente4ff283d8ae7f77b523a648e7c0dbbb1781008fe (diff)
downloadopenembedded-core-3bbebc39235f50af4d66e3284b67c1491d2c93f2.tar.gz
libcap-ng: Replace python patch with a better fix
By using the python3targetconfig class we can drop the existing python patch and the extra make parameters. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
index 43f76dc561..6cea422d11 100644
--- a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
@@ -4,14 +4,13 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/libcap-ng:"
SUMMARY .= " - python"
-inherit lib_package autotools python3native
+inherit lib_package autotools python3targetconfig
DEPENDS += "libcap-ng python3 swig-native"
S = "${WORKDIR}/libcap-ng-${PV}"
EXTRA_OECONF += "--with-python --with-python3"
-EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
do_install_append() {
rm -rf ${D}${bindir}