summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libmpc
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-05-02 18:41:53 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 11:17:37 +0100
commit7a667811afb3ce7178ee7050973a5c2c854405eb (patch)
tree52f8e1ed6b73dc906d1731575cc38936214681f6 /meta/recipes-support/libmpc
parent0ab7b586de076ae96cfa91b4f97815ea0893ef7f (diff)
downloadopenembedded-core-7a667811afb3ce7178ee7050973a5c2c854405eb.tar.gz
openembedded-core-7a667811afb3ce7178ee7050973a5c2c854405eb.tar.bz2
openembedded-core-7a667811afb3ce7178ee7050973a5c2c854405eb.zip
libmpc: fix build with automake 1.12
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-support/libmpc')
-rw-r--r--meta/recipes-support/libmpc/libmpc/libmpc_fix_for_automake-1.12.patch26
-rw-r--r--meta/recipes-support/libmpc/libmpc_0.8.2.bb5
2 files changed, 29 insertions, 2 deletions
diff --git a/meta/recipes-support/libmpc/libmpc/libmpc_fix_for_automake-1.12.patch b/meta/recipes-support/libmpc/libmpc/libmpc_fix_for_automake-1.12.patch
new file mode 100644
index 0000000000..75fa28e338
--- /dev/null
+++ b/meta/recipes-support/libmpc/libmpc/libmpc_fix_for_automake-1.12.patch
@@ -0,0 +1,26 @@
+Upstream-Status: Pending
+
+this fix avoids this error with automake 1.12
+
+| automake: warnings are treated as errors
+| /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libmpc.la': linking libtool libraries using a non-POSIX
+| /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/05/02
+
+Index: mpc-0.8.2/configure.ac
+===================================================================
+--- mpc-0.8.2.orig/configure.ac
++++ mpc-0.8.2/configure.ac
+@@ -86,6 +86,10 @@ AC_PROG_EGREP
+ AC_PROG_SED
+ AC_LANG(C)
+
++# automake 1.12 seems to require this, but automake 1.11 doesn't recognize it
++m4_pattern_allow([AM_PROG_AR])
++AM_PROG_AR
++
+ dnl Check for GMP CFLAGS in gmp.h
+ if test -z "$user_redefine_cc" ; then
+ MPC_GMP_CC_CFLAGS
diff --git a/meta/recipes-support/libmpc/libmpc_0.8.2.bb b/meta/recipes-support/libmpc/libmpc_0.8.2.bb
index f991a8e419..7a372bab68 100644
--- a/meta/recipes-support/libmpc/libmpc_0.8.2.bb
+++ b/meta/recipes-support/libmpc/libmpc_0.8.2.bb
@@ -2,10 +2,11 @@ require libmpc.inc
DEPENDS = "gmp mpfr"
-PR = "r0"
+PR = "r1"
LICENSE="LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
-SRC_URI = "http://www.multiprecision.org/mpc/download/mpc-${PV}.tar.gz"
+SRC_URI = "http://www.multiprecision.org/mpc/download/mpc-${PV}.tar.gz \
+ file://libmpc_fix_for_automake-1.12.patch"
SRC_URI[md5sum] = "e98267ebd5648a39f881d66797122fb6"
SRC_URI[sha256sum] = "ae79f8d41d8a86456b68607e9ca398d00f8b7342d1d83bcf4428178ac45380c7"