summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup
diff options
context:
space:
mode:
authorPhil Blundell <pb@pbcl.net>2014-01-09 11:16:10 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-10 15:13:36 +0000
commite588ba009402be27c643f2596acea0f178d4e42f (patch)
tree1e7484a2c1198e83cb9487ac4a96ed7acf42325a /meta/recipes-support/libsoup
parent6f9e72f77cd0b06c5ad753cb9ab05dd681690c6b (diff)
downloadopenembedded-core-e588ba009402be27c643f2596acea0f178d4e42f.tar.gz
openembedded-core-e588ba009402be27c643f2596acea0f178d4e42f.tar.bz2
openembedded-core-e588ba009402be27c643f2596acea0f178d4e42f.zip
libsoup: Remove libproxy from DEPENDS
Although libsoup did use to support direct usage of libproxy, it hasn't done so for some time. Worse, if libsoup depends on libproxy then it is impossible to build libproxy against webkit since webkit itself depends on libsoup in some configurations. Fix this by removing the extraneous entry from DEPENDS. Signed-off-by: Phil Blundell <pb@pbcl.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.45.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.45.3.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.45.3.bb
index ea062c7a97..b1199d8ce0 100644
--- a/meta/recipes-support/libsoup/libsoup-2.4_2.45.3.bb
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.45.3.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
SECTION = "x11/gnome/libs"
-DEPENDS = "glib-2.0 gnutls libxml2 libproxy sqlite3 intltool-native"
+DEPENDS = "glib-2.0 gnutls libxml2 sqlite3 intltool-native"
# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
# by default but let it be easily disabled.