summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.28.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-12-03 17:27:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:34 +0000
commitb3f32cd46d8ee8a17037365b9c2ab19bbf542c72 (patch)
tree7a6dc4c7340e7f4d8734a0dff82bb46b393d0761 /meta/recipes-support/libxslt/libxslt_1.1.28.bb
parent39b96435a8199a09c586ca0002ad447bf42058b8 (diff)
downloadopenembedded-core-b3f32cd46d8ee8a17037365b9c2ab19bbf542c72.tar.gz
libxslt: upgrade to 1.1.28
Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.28.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
new file mode 100644
index 0000000000..3f89e78df6
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "GNOME XSLT library"
+HOMEPAGE = "http://xmlsoft.org/XSLT/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
+
+SECTION = "libs"
+DEPENDS = "libxml2"
+PR = "r0"
+
+SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch"
+
+SRC_URI[md5sum] = "9667bf6f9310b957254fdcf6596600b7"
+SRC_URI[sha256sum] = "5fc7151a57b89c03d7b825df5a0fae0a8d5f05674c0e7cf2937ecec4d54a028c"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig binconfig lib_package
+
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e 's/ansidecl.h//' ${S}/configure.in
+}
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+# older versions of this recipe had ${PN}-utils
+RPROVIDES_${PN}-bin += "${PN}-utils"
+RCONFLICTS_${PN}-bin += "${PN}-utils"
+RREPLACES_${PN}-bin += "${PN}-utils"
+
+FILES_${PN} += "${libdir}/libxslt-plugins"
+FILES_${PN}-dev += "${libdir}/xsltConf.sh"
+
+BBCLASSEXTEND = "native"