summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.34.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-30 14:25:58 +0100
commit42344347be29f0997cc2f7636d9603b1fe1875ae (patch)
tree9a061dbb101c5baf3f4e8c8be1322a1794584f3c /meta/recipes-support/libxslt/libxslt_1.1.34.bb
parent72c04cb3ca78208a135275d6dd43ad500b663cb5 (diff)
downloadopenembedded-core-42344347be29f0997cc2f7636d9603b1fe1875ae.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.34.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.34.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.34.bb b/meta/recipes-support/libxslt/libxslt_1.1.34.bb
index 63cce6fe06..c888f3d7e1 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.34.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.34.bb
@@ -27,7 +27,7 @@ BINCONFIG = "${bindir}/xslt-config"
inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
-do_configure_prepend () {
+do_configure:prepend () {
# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
# This can be removed when upgrading to 1.1.34.
sed -i -e 's/ansidecl.h//' ${S}/configure.ac
@@ -39,20 +39,20 @@ do_configure_prepend () {
EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
# older versions of this recipe had ${PN}-utils
-RPROVIDES_${PN}-bin += "${PN}-utils"
-RCONFLICTS_${PN}-bin += "${PN}-utils"
-RREPLACES_${PN}-bin += "${PN}-utils"
+RPROVIDES:${PN}-bin += "${PN}-utils"
+RCONFLICTS:${PN}-bin += "${PN}-utils"
+RREPLACES:${PN}-bin += "${PN}-utils"
# This is only needed until libxml can load the relocated catalog itself
-do_install_append_class-native () {
+do_install:append:class-native () {
create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
}
-do_install_append () {
+do_install:append () {
oe_multilib_header libxslt/xsltconfig.h
}
-FILES_${PN} += "${libdir}/libxslt-plugins"
-FILES_${PN}-dev += "${libdir}/xsltConf.sh"
+FILES:${PN} += "${libdir}/libxslt-plugins"
+FILES:${PN}-dev += "${libdir}/xsltConf.sh"
BBCLASSEXTEND = "native nativesdk"