summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.34.bb
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-03-06 14:40:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-07 22:43:48 +0000
commit6b5b1486bbd381b2b657645e91a1712332ddcb94 (patch)
tree03a67c013890058bbc758edb154a44af6fb0dfae /meta/recipes-support/libxslt/libxslt_1.1.34.bb
parent5186d399b4e24273a35c9ad8b0c6fac8d626911a (diff)
downloadopenembedded-core-6b5b1486bbd381b2b657645e91a1712332ddcb94.tar.gz
libxslt: update to v1.1.35
Security [CVE-2021-30560] Fix use-after-free in xsltApplyTemplates Fix memory leak in xsltDocumentElem (David King) Fix memory leak in xsltCompileIdKeyPattern (David King) Fix double-free with stylesheets containing entity nodes Fixed regressions Fix performance regression with predicates in patterns Fix regression in xsltComputeSortResult Bug fixes Fix conflict resolution for templates with same priority Fix xsl:number generating invalid UTF-8 Support attribute value templates in xsl:sort lang attributes Don't pass first xsl:sort in xsl:apply-templates twice Fix quadratic runtime with text and xsl:message Don't allow empty EXSLT durations Improvements Add xsltproc --huge Argument via libxml XML_PARSE_HUGE (William N. Braswell, Jr.) Tests, code quality, fuzzing Remove .travis.yml Fix some misleading indentation (David King) Use actual types for templates in struct _xsltStylesheet Add CI for CMake on MSVC (Markus Rickert) Check for null pointer before calling freelocale Add CI test for Python 3 Don't set maxDepth in XPath contexts Transfer XPath limits to XPtr context Stop using maxParserDepth XPath limit Make long-to-double cast explicit in date.c Disable LeakSanitizer Run clang CI tests with -Wimplicit-int-conversion Fix implicit-int-conversion warning in exslt/crypto.c Fix clang -Wimplicit-int-conversion warning (David Kilzer) Fix clang -Wconditional-uninitialized warning in libxslt/numbers.c (David Kilzer) Fix -Wshadow warnings in libexslt/dynamic.c (David Kilzer) Also search parent dir for source XML when fuzzing Build system, portability Add CMake build files (Markus Rickert) Initial support for Python 3 (Suleyman Poyraz) Call ANSI versions of WinAPI functions explicitly Remove redundant flags from pkg-config files Suppress automake warning in tests/XSLTMark Fix linking libexslt dynamic library when using MinGW (Vadim Zeitlin) Added platform specific path separators (Dmitriy Korovkin) win32: allow passing *FLAGS on command line Fix export of xsltExtMarker on Windows (David Kilzer) Fix redundant includes already in libexslt.h (David Kilzer) Minor fixes to configure.js Fix variable syntax in Python configuration Add new EXSLT string tests to EXTRA_DIST Fix xml2-config check in configure script win32: Add configuration for profiler (Chun-wei Fan) Check whether 'xml2-config --dynamic' is supported Documentation Add Makefile rule to regenerate xsltproc.html Update links Remove MAINTAINERS Upload documentation to GitLab Pages Add documentation in devhelp format Add --enable-rebuild-docs configure option Fix libexslt header summaries Fix validity of tutorial XML (David King) Use DocBook URL for tutorial DTD (David King) Update libxslt.doap Add missing options to xsltproc man page Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.34.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.34.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.34.bb b/meta/recipes-support/libxslt/libxslt_1.1.34.bb
deleted file mode 100644
index c888f3d7e1..0000000000
--- a/meta/recipes-support/libxslt/libxslt_1.1.34.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-SUMMARY = "GNOME XSLT library"
-DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \
-XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \
-libxml2 the XML C library developed for the GNOME project. It also implements most of \
-the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \
-and expressions extensions."
-HOMEPAGE = "http://xmlsoft.org/XSLT/"
-BUGTRACKER = "https://bugzilla.gnome.org/"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
-
-SECTION = "libs"
-DEPENDS = "libxml2"
-
-SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \
- "
-
-SRC_URI[md5sum] = "db8765c8d076f1b6caafd9f2542a304a"
-SRC_URI[sha256sum] = "98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f"
-
-UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
-
-S = "${WORKDIR}/libxslt-${PV}"
-
-BINCONFIG = "${bindir}/xslt-config"
-
-inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
-
-do_configure:prepend () {
- # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
- # This can be removed when upgrading to 1.1.34.
- sed -i -e 's/ansidecl.h//' ${S}/configure.ac
-
- # The timestamps in the 1.1.28 tarball are messed up causing this file to
- # appear out of date. Touch it so that we don't try to regenerate it.
- touch ${S}/doc/xsltproc.1
-}
-
-EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
-# older versions of this recipe had ${PN}-utils
-RPROVIDES:${PN}-bin += "${PN}-utils"
-RCONFLICTS:${PN}-bin += "${PN}-utils"
-RREPLACES:${PN}-bin += "${PN}-utils"
-
-# This is only needed until libxml can load the relocated catalog itself
-do_install:append:class-native () {
- create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
-}
-
-do_install:append () {
- oe_multilib_header libxslt/xsltconfig.h
-}
-
-FILES:${PN} += "${libdir}/libxslt-plugins"
-FILES:${PN}-dev += "${libdir}/xsltConf.sh"
-
-BBCLASSEXTEND = "native nativesdk"