summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/shared-mime-info
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2012-06-07 16:37:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-08 11:37:05 +0100
commit6fef8f73143fdeed6da15444c11bce9a8b35668b (patch)
treed05c616f5279f5352f02d9414802493b9a11bcbc /meta/recipes-support/shared-mime-info
parenteb6fb917b7a6745b296c8ae0a5bf66f498bf3576 (diff)
downloadopenembedded-core-6fef8f73143fdeed6da15444c11bce9a8b35668b.tar.gz
shared-mime-info: fix build race condition
The definition of install-data-hook in Makefile.am leads to multiple, overlapping, executions of the install-binPROGRAMS target. We modify the definition to avoid that. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/shared-mime-info')
-rw-r--r--meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch21
-rw-r--r--meta/recipes-support/shared-mime-info/shared-mime-info_0.91.bb5
2 files changed, 24 insertions, 2 deletions
diff --git a/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch b/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
new file mode 100644
index 0000000000..4c075f2549
--- /dev/null
+++ b/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
@@ -0,0 +1,21 @@
+fix shared-mime-info build race condition
+
+The definition of install-data-hook in Makefile.am leads
+to multiple, overlapping, executions of install-binPROGRAMS
+target. We modify the definition to avoid that.
+
+Signed-off-by: Joe Slater <jslater@windriver.com>
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -44,7 +44,9 @@ $(pkgconfig_DATA): config.status
+ @INTLTOOL_XML_RULE@
+ @INTLTOOL_DESKTOP_RULE@
+
+-install-data-hook: install-binPROGRAMS
++# do NOT make this dependent on anything!
++#
++install-data-hook:
+ if ENABLE_UPDATE_MIMEDB
+ $(DESTDIR)"$(bindir)/update-mime-database" -V "$(DESTDIR)$(datadir)/mime"
+ endif
diff --git a/meta/recipes-support/shared-mime-info/shared-mime-info_0.91.bb b/meta/recipes-support/shared-mime-info/shared-mime-info_0.91.bb
index 7ae6e10962..910cb7fc5d 100644
--- a/meta/recipes-support/shared-mime-info/shared-mime-info_0.91.bb
+++ b/meta/recipes-support/shared-mime-info/shared-mime-info_0.91.bb
@@ -1,7 +1,8 @@
require shared-mime-info.inc
-PR = "r3"
+PR = "r4"
SRC_URI[md5sum] = "982a211560ba4c47dc791ccff34e8fbc"
SRC_URI[sha256sum] = "98cfebe1d809afb24934e634373821e2a1dfa86fc6462cab230589a1c80988bd"
-SRC_URI =+ "file://parallelmake.patch"
+SRC_URI =+ "file://parallelmake.patch \
+ file://install-data-hook.patch"