summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/taglib/taglib_1.11.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-11-22 11:19:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:08 +0000
commit6a56ff7885f43abdb3b9bfeb733be6fee1de237c (patch)
treed1ba38be52ac70ef2ffe77d4b8605cba29648906 /meta/recipes-support/taglib/taglib_1.11.1.bb
parentaf280990bff4a484fd8a18e3442b56a0a39b7611 (diff)
downloadopenembedded-core-6a56ff7885f43abdb3b9bfeb733be6fee1de237c.tar.gz
taglib: Update to 1.11.1
Forcibly disable Boost as the macros it looks for are also present in our C++ standard library. Enable c++11 in cmake as well as in CXXFLAGS [Khem Raj] CXXFLAGS is required due to a cmake bug where it does not honor CMAKE_CXX_FLAGS during configure time checks [Khem Raj] Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/taglib/taglib_1.11.1.bb')
-rw-r--r--meta/recipes-support/taglib/taglib_1.11.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-support/taglib/taglib_1.11.1.bb b/meta/recipes-support/taglib/taglib_1.11.1.bb
new file mode 100644
index 0000000000..ee1b5234bb
--- /dev/null
+++ b/meta/recipes-support/taglib/taglib_1.11.1.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
+SECTION = "libs/multimedia"
+HOMEPAGE = "http://taglib.github.io/"
+LICENSE = "LGPLv2.1 | MPL-1"
+LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
+ file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
+
+DEPENDS = "zlib"
+
+SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
+SRC_URI[md5sum] = "cee7be0ccfc892fa433d6c837df9522a"
+SRC_URI[sha256sum] = "b6d1a5a610aae6ff39d93de5efd0fdc787aa9e9dc1e7026fa4c961b26563526b"
+
+UPSTREAM_CHECK_URI = "http://github.com/taglib/taglib/releases/"
+
+BINCONFIG = "${bindir}/taglib-config"
+
+inherit cmake pkgconfig binconfig-disabled
+
+PACKAGES =+ "${PN}-c"
+FILES_${PN}-c = "${libdir}/libtag_c.so.*"
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
+ -DHAVE_BOOST_BYTESWAP=FALSE \
+ -DCMAKE_CXX_STANDARD=11 \
+ -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
+ -DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')} \
+"
+CXXFLAGS += "-std=c++11"
+
+do_configure_prepend () {
+ rm -f ${S}/admin/ltmain.sh
+ rm -f ${S}/admin/libtool.m4.in
+}
+
+# without -fPIC depending packages failed with many error like:
+# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
+CXXFLAGS += "-fPIC"