summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>2012-12-05 16:40:06 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:37 +0000
commit07501f14121a1882f26de66b4ca991392ab45dff (patch)
tree8caeface7ef712e391bc834d6eae773c9f0d9382 /meta
parent62db8745c1b907ebec222751cd9cb174dd5f2f96 (diff)
downloadopenembedded-core-07501f14121a1882f26de66b4ca991392ab45dff.tar.gz
libaio: Remove QA warning: No GNU_HASH in the elf binary
Update the LINK_FLAGS in the Makefile to remove warning: QA Issue: No GNU_HASH in the elf binary Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/libaio/libaio_0.3.109.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-extended/libaio/libaio_0.3.109.bb b/meta/recipes-extended/libaio/libaio_0.3.109.bb
index 161b712a48..0712d04e71 100644
--- a/meta/recipes-extended/libaio/libaio_0.3.109.bb
+++ b/meta/recipes-extended/libaio/libaio_0.3.109.bb
@@ -18,6 +18,10 @@ SRC_URI[sha256sum] = "bf4a457253cbaab215aea75cb6e18dc8d95bbd507e9920661ff9bdd288
EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
+do_configure () {
+ sed -i 's#LINK_FLAGS=.*#LINK_FLAGS=$(LDFLAGS)#' src/Makefile
+}
+
do_install () {
oe_runmake install DESTDIR=${D}
}