summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-05-09 14:46:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:00:30 +0100
commit5e7d337fd538325e5f69de5b409eb8e36bb5e007 (patch)
treecb5591048324f96cbc7b9050cc577040656a90ef /meta
parentc4ceaaea207e15bafd4261c33fd20fdf66d50c7d (diff)
downloadopenembedded-core-5e7d337fd538325e5f69de5b409eb8e36bb5e007.tar.gz
distcc: move ASNEEDED over-ride into the distcc recipe
Move the recipe specific over-ride for ASNEEDED into the recipe to make it more apparent that the over-ride is being applied (and that it should be re-checked on version updates, etc). Also misc minor recipe cleanup (re-order variables to follow the OE style guide, etc). Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/distro/include/as-needed.inc1
-rw-r--r--meta/recipes-devtools/distcc/distcc_3.2.bb29
2 files changed, 20 insertions, 10 deletions
diff --git a/meta/conf/distro/include/as-needed.inc b/meta/conf/distro/include/as-needed.inc
index 91c0762727..94f5b90593 100644
--- a/meta/conf/distro/include/as-needed.inc
+++ b/meta/conf/distro/include/as-needed.inc
@@ -1,7 +1,6 @@
ASNEEDED = "-Wl,--as-needed"
-ASNEEDED_pn-distcc = ""
ASNEEDED_pn-openobex = ""
ASNEEDED_pn-icu = ""
ASNEEDED_pn-pciutils = ""
diff --git a/meta/recipes-devtools/distcc/distcc_3.2.bb b/meta/recipes-devtools/distcc/distcc_3.2.bb
index 66046480b9..ee077495d5 100644
--- a/meta/recipes-devtools/distcc/distcc_3.2.bb
+++ b/meta/recipes-devtools/distcc/distcc_3.2.bb
@@ -7,13 +7,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "avahi binutils"
-PACKAGECONFIG ??= "popt"
-PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
-# use system popt by default
-PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
-
-RRECOMMENDS_${PN} = "avahi-daemon"
-
SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
file://separatebuilddir.patch \
file://0001-zeroconf-Include-fcntl.h.patch \
@@ -21,12 +14,26 @@ SRC_URI = "git://github.com/akuster/distcc.git;branch=${PV} \
file://distccmon-gnome.desktop \
file://distcc \
file://distcc.service"
+
SRCREV = "d8b18df3e9dcbe4f092bed565835d3975e99432c"
+
S = "${WORKDIR}/git"
inherit autotools pkgconfig update-rc.d useradd systemd
-EXTRA_OECONF += "--disable-Werror PYTHON='' --disable-pump-mode"
+PACKAGECONFIG ??= "popt"
+
+PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
+# use system popt by default
+PACKAGECONFIG[popt] = "--without-included-popt,--with-included-popt,popt"
+
+EXTRA_OECONF += " \
+ --disable-pump-mode \
+ --disable-Werror \
+ PYTHON='' \
+"
+
+ASNEEDED = ""
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system \
@@ -52,18 +59,22 @@ do_install() {
sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_unitdir}/system/distcc.service
${DESKTOPINSTALL}
}
+
DESKTOPINSTALL = ""
DESKTOPINSTALL_libc-glibc () {
install -d ${D}${datadir}/distcc/
install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
}
+
PACKAGES += "distcc-distmon-gnome"
FILES_${PN} = " ${sysconfdir} \
${bindir}/distcc \
- ${bindir}/lsdistcc \
+ ${bindir}/lsdistcc \
${bindir}/distccd \
${bindir}/distccmon-text \
${systemd_unitdir}/system/distcc.service"
FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
${datadir}/distcc"
+
+RRECOMMENDS_${PN} = "avahi-daemon"