summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2011-02-22 20:36:45 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2011-03-01 11:46:01 +0000
commitc82a6ae77941d51fb77d265eccbdcda51bfec5fb (patch)
tree267696d0056eb22b782eec9b2548d67ce41db30a /meta
parentd78290fe0ce04ad0861fc807569be0ebc7395de1 (diff)
downloadopenembedded-core-c82a6ae77941d51fb77d265eccbdcda51bfec5fb.tar.gz
xf86-video-intel: add config option to support rootless X
- add global config option ROOTLESS_X to control if enable rootless X for the machine. ROOTLESS_X requires graphics driver supporting KMS (kernel mode setting), so far, only atom_pc support this. so enable ROOTLESS_X for atom_pc machine - add config options for xf86-video-intel to support rootless X Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/machine/atom-pc.conf2
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-intel_2.14.0.bb5
2 files changed, 7 insertions, 0 deletions
diff --git a/meta/conf/machine/atom-pc.conf b/meta/conf/machine/atom-pc.conf
index 58c9b0da65..b94deb20e5 100644
--- a/meta/conf/machine/atom-pc.conf
+++ b/meta/conf/machine/atom-pc.conf
@@ -42,3 +42,5 @@ GLIBC_ADDONS = "nptl"
GLIBC_EXTRA_OECONF = "--with-tls"
EXTRA_OECONF_append_pn-matchbox-panel-2 = " --with-battery=acpi"
+
+ROOTLESS_X = "1"
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.14.0.bb b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.14.0.bb
index 017a2e0a28..099cf9dff2 100644
--- a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.14.0.bb
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.14.0.bb
@@ -9,8 +9,13 @@ Infrastructure (DRI)."
LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e"
+PR = "r1"
+
EXTRA_OECONF += "--disable-xvmc"
+# --enable-kms-only option is required by ROOTLESS_X
+EXTRA_OECONF += '${@base_conditional( "ROOTLESS_X", "1", " --enable-kms-only", "", d )}'
+
DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
virtual/libgl xineramaproto xf86driproto libpciaccess"