summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
index 92e52b9bac..8c1cf5b7e2 100644
--- a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
+++ b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
@@ -6,7 +6,7 @@ DEPENDS = "dbus-native dbus dbus-glib"
RDEPENDS = "gsm0710muxd"
LICENSE = "GPL"
PV = "0.1.0+gitr${SRCREV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master \
file://fix-dbus-location.patch;patch=1"
@@ -19,8 +19,12 @@ EXTRA_OECONF = "--disable-tests"
do_install_append () {
install -d ${D}${sysconfdir}/gsmd2
+
install -d ${D}${sysconfdir}/dbus-1/system.d/
install -m 0644 ${S}/res/freesmartphone.conf ${D}${sysconfdir}/dbus-1/system.d/
+
+ install -d ${D}${datadir}/dbus-1/system-services
+ install -m 0644 ${S}/gsmd2.service ${D}${datadir}/dbus-1/system-services/
}
PACKAGES =+ "libgsmd2 libfreesmartphone"
@@ -28,4 +32,4 @@ PACKAGES =+ "libgsmd2 libfreesmartphone"
FILES_libgsmd2 = "${libdir}/libgsmd2.so.* ${libdir}/gsmd2/*.so"
FILES_libfreesmartphone = "${libdir}/libfreesmartphone.so.*"
FILES_${PN}-dev += "${libdir}/gsmd2/*.*a"
-FILES_${PN} = "${bindir}/gsmd2 ${sysconfdir}/dbus-1/"
+FILES_${PN} = "${bindir}/gsmd2 ${sysconfdir}/dbus-1/ ${datadir}/dbus-1/"