summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/conf/distro/include/maintainers.inc1
-rw-r--r--meta/conf/distro/include/ptest-packagelists.inc75
-rw-r--r--meta/recipes-sato/images/core-image-sato-ptest-fast.bb16
3 files changed, 92 insertions, 0 deletions
diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index 950b8e8951..41c2a95d53 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -122,6 +122,7 @@ RECIPE_MAINTAINER_pn-core-image-clutter = "Richard Purdie <richard.purdie@linuxf
RECIPE_MAINTAINER_pn-core-image-weston = "Richard Purdie <richard.purdie@linuxfoundation.org>"
RECIPE_MAINTAINER_pn-core-image-x11 = "Richard Purdie <richard.purdie@linuxfoundation.org>"
RECIPE_MAINTAINER_pn-core-image-sato-dev = "Richard Purdie <richard.purdie@linuxfoundation.org>"
+RECIPE_MAINTAINER_pn-core-image-sato-ptest-fast = "Richard Purdie <richard.purdie@linuxfoundation.org>"
RECIPE_MAINTAINER_pn-core-image-sato-sdk-ptest = "Richard Purdie <richard.purdie@linuxfoundation.org>"
RECIPE_MAINTAINER_pn-coreutils = "Chen Qi <Qi.Chen@windriver.com>"
RECIPE_MAINTAINER_pn-cpio = "Denys Dmytriyenko <denys@ti.com>"
diff --git a/meta/conf/distro/include/ptest-packagelists.inc b/meta/conf/distro/include/ptest-packagelists.inc
new file mode 100644
index 0000000000..768ba743ed
--- /dev/null
+++ b/meta/conf/distro/include/ptest-packagelists.inc
@@ -0,0 +1,75 @@
+#
+# Lists of the ptests in OE-Core, sorted into two sets by the time they take
+#
+# ptests which take less than ~30s each
+#
+PTESTS_FAST = "\
+ acl-ptest \
+ apr-ptest \
+ apr-util-ptest \
+ attr-ptest \
+ bluez5-ptest \
+ bzip2-ptest \
+ dbus-test-ptest \
+ diffstat-ptest \
+ diffutils-ptest \
+ elfutils-ptest \
+ ethtool-ptest \
+ flex-ptest \
+ gawk-ptest \
+ gdbm-ptest \
+ gdk-pixbuf-ptest \
+ gzip-ptest \
+ json-glib-ptest \
+ kbd-ptest \
+ libconvert-asn1-perl-ptest \
+ liberror-perl-ptest \
+ libpcre-ptest \
+ libtimedate-perl-ptest \
+ libtest-needs-perl-ptest \
+ liburi-perl-ptest \
+ libusb1-ptest \
+ libxml-namespacesupport-perl-ptest \
+ libxml-perl-ptest \
+ libxml-parser-perl-ptest \
+ libxml-sax-perl-ptest \
+ libxml-sax-base-perl-ptest \
+ libxml-simple-perl-ptest \
+ libxml2-ptest \
+ lzo-ptest \
+ nettle-ptest \
+ openssl-ptest \
+ opkg-ptest \
+ pango-ptest \
+ parted-ptest \
+ quilt-ptest \
+ sed-ptest \
+ slang-ptest \
+ zlib-ptest \
+"
+
+#PTESTS_PROBLEMS = "\
+# qemu-ptest \ # Doesn't run any tests?
+# ruby-ptest \ # Timeout
+# mdadm-ptest \ # Timeout
+# clutter-1.0-ptest \ # Doesn't build due to depends on cogl-1.0
+#"
+
+PTESTS_SLOW = "\
+ bash-ptest \
+ busybox-ptest \
+ e2fsprogs-ptest \
+ glib-2.0-ptest \
+ gstreamer1.0-ptest \
+ libevent-ptest \
+ lttng-tools-ptest \
+ openssh-ptest \
+ openssl-ptest \
+ perl-ptest \
+ python-ptest \
+ python3-ptest \
+ strace-ptest \
+ tcl-ptest \
+ util-linux-ptest \
+ valgrind-ptest \
+"
diff --git a/meta/recipes-sato/images/core-image-sato-ptest-fast.bb b/meta/recipes-sato/images/core-image-sato-ptest-fast.bb
new file mode 100644
index 0000000000..b794a7dc9e
--- /dev/null
+++ b/meta/recipes-sato/images/core-image-sato-ptest-fast.bb
@@ -0,0 +1,16 @@
+require core-image-sato-sdk.bb
+require conf/distro/include/ptest-packagelists.inc
+
+IMAGE_INSTALL += "${PTESTS_FAST}"
+
+DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
+
+# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
+# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
+# box) and explicitly add just 1500MB.
+# strace-ptest in particular needs more than 500MB
+IMAGE_OVERHEAD_FACTOR = "1.0"
+IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
+
+# ptests need more memory than standard to avoid the OOM killer
+QB_MEM = "-m 1024"