summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-support/vim/vim-tiny_8.1.1017.bb2
-rw-r--r--meta/recipes-support/vim/vim_8.1.1017.bb18
2 files changed, 11 insertions, 9 deletions
diff --git a/meta/recipes-support/vim/vim-tiny_8.1.1017.bb b/meta/recipes-support/vim/vim-tiny_8.1.1017.bb
index 8b1fb7b115..74464833ad 100644
--- a/meta/recipes-support/vim/vim-tiny_8.1.1017.bb
+++ b/meta/recipes-support/vim/vim-tiny_8.1.1017.bb
@@ -8,7 +8,7 @@ ALTERNATIVE_${PN}_remove = "xxd"
PACKAGECONFIG += "tiny"
do_install() {
- install -D -m 0755 ${S}/vim ${D}/${bindir}/vim.tiny
+ install -D -m 0755 ${S}/src/vim ${D}/${bindir}/vim.tiny
}
ALTERNATIVE_PRIORITY = "90"
diff --git a/meta/recipes-support/vim/vim_8.1.1017.bb b/meta/recipes-support/vim/vim_8.1.1017.bb
index 7627d2844b..4e3e663c54 100644
--- a/meta/recipes-support/vim/vim_8.1.1017.bb
+++ b/meta/recipes-support/vim/vim_8.1.1017.bb
@@ -6,16 +6,16 @@ DEPENDS = "ncurses gettext-native"
# vimdiff doesn't like busybox diff
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72"
+LIC_FILES_CHKSUM = "file://runtime/doc/uganda.txt;endline=287;md5=f1f82b42360005c70b8c19b0ef493f72"
SRC_URI = "git://github.com/vim/vim.git \
- file://disable_acl_header_check.patch;patchdir=.. \
- file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
- file://0001-src-Makefile-improve-reproducibility.patch;patchdir=.. \
+ file://disable_acl_header_check.patch \
+ file://vim-add-knob-whether-elf.h-are-checked.patch \
+ file://0001-src-Makefile-improve-reproducibility.patch \
"
SRCREV = "493fbe4abee660d30b4f2aef87b754b0a720213c"
-S = "${WORKDIR}/git/src"
+S = "${WORKDIR}/git"
VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}"
@@ -25,13 +25,15 @@ CLEANBROKEN = "1"
# vim configure.in contains functions which got 'dropped' by autotools.bbclass
do_configure () {
+ cd src
rm -f auto/*
touch auto/config.mk
aclocal
autoconf
+ cd ..
oe_runconf
- touch auto/configure
- touch auto/config.mk auto/config.h
+ touch src/auto/configure
+ touch src/auto/config.mk src/auto/config.h
}
#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
@@ -76,7 +78,7 @@ do_install() {
chmod -x ${D}${datadir}/${BPN}/${VIMDIR}/tools/*.py
# Install example vimrc from runtime files
- install -m 0644 ../runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
+ install -m 0644 runtime/vimrc_example.vim ${D}/${datadir}/${BPN}/vimrc
# we use --with-features=big as default
mv ${D}${bindir}/${BPN} ${D}${bindir}/${BPN}.${BPN}