summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.8.bb b/meta/recipes-support/libevent/libevent_2.1.8.bb
index 83ce4644cf..0f91e05a6c 100644
--- a/meta/recipes-support/libevent/libevent_2.1.8.bb
+++ b/meta/recipes-support/libevent/libevent_2.1.8.bb
@@ -28,12 +28,16 @@ inherit autotools
# Needed for Debian packaging
LEAD_SONAME = "libevent-2.1.so"
-inherit ptest
+inherit ptest multilib_header
DEPENDS = "zlib"
BBCLASSEXTEND = "native nativesdk"
+do_install_append() {
+ oe_multilib_header event2/event-config.h
+}
+
do_install_ptest() {
install -d ${D}${PTEST_PATH}/test
for file in ${B}/test/.libs/regress ${B}/test/.libs/test*