summaryrefslogtreecommitdiffstats
path: root/bitbake/bin/bitbake
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake/bin/bitbake')
-rwxr-xr-xbitbake/bin/bitbake3
1 files changed, 2 insertions, 1 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 7880968965..600cdadc9d 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -206,7 +206,8 @@ Default BBFILES are the .bb files in the current directory.""")
print "FATAL: Invalid user interface '%s' specified. " % ui
print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
except Exception, e:
- print "FATAL: Unable to start to '%s' UI due to exception: %s." % (configuration.ui, e)
+ print "FATAL: Unable to start to '%s' UI: %s" % (configuration.ui, e)
+ raise
finally:
serverConnection.terminate()
return return_value